1

Recently, I had to re-root my nook simple touch after the stock recovery removed the su binary. Unfortunately, it deleted my settings for remapping my upper left page button to use as a CTRL key. I would love to go back to using the terminal app running an Ubuntu Distro.

I tried fixing the problem by installing the patched jars needed for nook touch tools. Although, I successfully installed them but when I go to the app to do the remapping the CTRL option no longer exists in the list of options!

I already found my keymap file in this directory

/system/usr/keylayout/

The file is named TWL4030_Keypad.kl

The content of the TWL4030_Keypad.kl file is here.

    key 399   GRAVE
key 2     1
key 3     2
key 4     3
key 5     4
key 6     5
key 7     6
key 8     7
key 9     8
key 10    9
key 78    0
key 158   BACK              WAKE_DROPPED
key 14    BACK              WAKE_DROPPED
key 230   SOFT_RIGHT        WAKE
key 106   SOFT_RIGHT        WAKE
key 107   ENDCALL           WAKE_DROPPED
key 62    ENDCALL           WAKE_DROPPED
key 60    ENDCALL           WAKE_DROPPED
key 229   MENU              WAKE_DROPPED
key 139   MENU              WAKE_DROPPED
key 59    MENU              WAKE_DROPPED
key 127   SEARCH            WAKE_DROPPED
key 217   SEARCH            WAKE_DROPPED
key 228   POUND
key 66    POUND
key 227   STAR
key 65    STAR
key 231   CALL              WAKE_DROPPED
key 102   CALL              WAKE_DROPPED
key 232   DPAD_CENTER       WAKE_DROPPED
key 108   DPAD_DOWN         WAKE_DROPPED
key 103   DPAD_UP           WAKE_DROPPED
key 63    HOME              WAKE
key 105   DPAD_LEFT         WAKE_DROPPED
key 106   DPAD_RIGHT        WAKE_DROPPED
key 115   VOLUME_UP
key 114   VOLUME_DOWN
key 116   POWER             WAKE
key 212   CAMERA
key 148   DPAD_CENTER
key 149   SEARCH
key 202   EXPLORER
key 203   ENVELOPE
key 102   HOME
key 16    Q
key 17    W
key 18    E
key 19    R
key 20    T
key 21    Y
key 22    U
key 23    I
key 24    O
key 25    P
key 26    LEFT_BRACKET
key 27    RIGHT_BRACKET
key 43    BACKSLASH
key 30    A
key 31    S
key 32    D
key 33    F
key 34    G
key 35    H
key 36    J
key 37    K
key 38    L
key 39    SEMICOLON
key 40    APOSTROPHE
key 61    DEL
key 353   ENTER
key 44    Z
key 45    X
key 46    C
key 47    V
key 48    B
key 49    N
key 50    M
key 51    COMMA
key 52    PERIOD
key 53    SLASH
key 28    ENTER
key 56    ALT_LEFT
key 100   ALT_RIGHT
key 42    ALT_LEFT
key 54    SHIFT_RIGHT
key 15    TAB
key 57    SPACE
key 150   EXPLORER
key 155   ENVELOPE
key 58    SHIFT_RIGHT
key 12    MINUS
key 13    EQUALS
key 215   AT
key 407   RIGHT_NEXTPAGE
key 412   CTRL_LEFT       <----------Here I tried to edit the file in adb 
key 139   LEFT_PREVPAGE              but is not recognized by the nook.
key 158   RIGHT_PREVPAGE
1

I furnished two solutions to my problem.

Get into the nook touch tools app and set up key bindings by clicking the button on the far right. You should see something like this. Where it says, left-bottom button select the option Volume_Down.

IMG:

After rebooting get into the terminal app's settings to set up key bindings.

The terminal app has options that permit you set up key bindings that will allow me to emulate the control key.

I have taken screenshots of the terminal's settings. I go into nook touch tools and set up the binding to use the left bottom page button to be used as a volume button. You must do this for it to work. Select preferences.

IMG:

The next step is to go to keyboard and you'll see the select control key option. Under the sub-list of options select volume-down for use as the CTRL key. Then you can now use the left bottom page button as the control key.

IMG:

The second option is to download the hacker's keyboard and install the multi-touch zips with the CWM based recovery on a sdcard via re-boot. But the ctrl key doesn't work so you still have to set up the settings in the terminal app. The multi-touch hack allows you to use two keys at the same time therefore allowing the binding of the alt key to be used as the ctrl key.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.