1

This is driving me bonkers. I've been on a chat with Vodafone and they sent me APN settings, but that hasn't helped. I've tried the settings in this thread. And that hasn't helped this time (it did a few months ago!!)

If I drop to a CMD prompt, on Windows 10 I can see that DNS is not working.

C:\Users\music>nslookup google.com
Server: UnKnown
Address: ::1

*** UnKnown can't find google.com: No response from server

which is really odd.

So, I tried to hit the IP address of one of my own web sites, which works.

It's definitely a DNS problem, and I guess the DHCP on the phone is not giving me any DNS server address to use, but how do I force it to do that? I've tried putting static details, and just using 8.8.8.8 and 4.4.4.4 as DNS, but it didn't help at all.

  • Is chrome browser what you are only trying to search with or have you tried other browsers? If only chrome maybe clearing/flushing the DNS cache might help. Url Address: chrome://net-internals/#dns – Bo Lawson Dec 21 '18 at 11:04
  • I've tried within a Windows CMD prompt, and I can ping 8.8.8.8 for example, but if I try to ping google.com I get the error message shown above. – Steve Button Dec 21 '18 at 11:30
  • Also I have tried in ms Edge and I got the same behaviour. – Steve Button Dec 21 '18 at 16:05
  • This might help: android.stackexchange.com/a/205740/218526 – Irfan Latif Dec 28 '18 at 18:09
0

This always happens if Vodafone send an update to the APN ... to fix it, just reset your APN settings back to default and select either pre-pay or post-pay, whatever's appropriate for your sim.

  • I tried that. Also, tried changing the APN type to various combinations of "default, supl, mms, ia, dun" but NONE of that seemed to help. The weird thing is if I try to ping a known IP address on the internet it works just fine. It's only my DNS that isn't working. Obviously speaking to Voda they weren't much help. I got them to sent me a new settings OTA, but it didn't help. I've got it working using a USB cable, but it will not play ball using Wifi hotspot at all. – Steve Button Mar 14 at 10:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.