0

Lately I'm experiencing this problem when connecting my LG G2 smartphone to the PC: I cannot see it anymore in explorer. I can actually connect to it tru ADB and push/pull files no problem. Also ADB shell works, developer options / debug USB enabled. In Windows registry / System I got a critical error event id 10110 - 10111 DriverFrameworks-UserMode each time I connect it to usb.

Drivers are installed, cable is ok, I tried on several PC and can't see it, also tried with Linux, same problem.

If I dmesg | grep usb I got these two errors:

<3>usb_bam_ipa_create_resources: Failed to create USB_PROD resource
<3>init: cannot find '/system/bin/usbdebug-manager', disabling 'usbdebug-manager'

I'm 100% sure is not a problem PC side, but smartphone side. I've been repacking /system/app and system/framework app to slim down my system, but I cannot figure out what is wrong.

LG G2 KK modified stock rom, Dorimanx Kernel

  • It sounds like the drivers maybe corrupted. Try un-installing and then re-installing (If possible updated) drivers? You could also try toggling the different usb modes such as mtp , ptp, and others. Debloating did you un-install a system app that had Mtp in name? – Bo Lawson Dec 21 '18 at 14:11
  • 1
    I learned something new android has a connection assistant for usb troubleshooting. This would be good with your linux machine: developer.android.com/studio/run/device I do not know what process 954 is but something bad happened (obviously) and your linux machine reset high Speed usb for device number 6 (whatever device 6 is probably your android) which is pretty crazy to do in the middle of an operation. Is your data cable connecting your device to the linux machine old? Maybe try another chord. – Bo Lawson Dec 21 '18 at 19:01
  • 1
    What does the command mtp-detect return on your linux machine? – Bo Lawson Dec 21 '18 at 19:24
  • 1
    That failed anyway Linux: Try editing/adding udev rules. Here is a walk through under Linux: developer.oculus.com/documentation/mobilesdk/0.4/concepts/… Make sure the not folder all did not get removed when Debloating seach with a file explorer for mtp should look something com.android.mtp or com.your_manufacturer.mtp What version of linux? – Bo Lawson Dec 22 '18 at 12:59
  • 1
    That didn't work either. I searched into the original image file I downloaded, there's no mtp system app. Btw, if I enter TWRP recovery and plug usb cable I see my device straight in explorer no problem – Ju Tutt Dec 22 '18 at 17:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.