4

I have a Lenovo Tab 4 10-inch tablet (Lenovo TB-X304F). Recently I had an error on it and had to perform a factory reset, and I'm experiencing problems reinstalling some apps I had installed before.

I have never rooted this tablet. Before the factory reset I did install some non-Google Play apps, but since the factory reset I have only installed apps from the Google Play Store. The tablet and apps are up to date, and the tablet is running Android 8.1.0.

Here is the most recent app problem. I purchased "Planescape: Torment" on November 11, and I installed it on my tablet around that time. However, now that I'm trying to install it again after performing the factory reset, I've had two errors, depending on the method I use to try to install it.

If I try to install it using the Google Play app on my tablet, it says "Your order is processing, your item will be available in a few minutes." (And I did not purchase this recently; I purchased it well over a month ago.) It lists the app as being $9.99 when I view it, as though I hadn't bought it, but when I tap on the button as though I'm going to purchase it, Google Play asks for the standard app permissions and then shows that error. It does exactly the same thing when I try to install it from the library list of all of my apps in the Google Play app.

Error message on tablet

If I try to install it from the Google Play website, the website tells me it's already installed on my tablet, which is no longer true. It used to be installed; it is not now.

Message in Web browser

I've cleared the cache and the data from the "Google Play Store" app and the "Google Play services" app. I chatted with Google Customer Support and they had me uninstall updates to the Google Play Store and then update it again, but that made no difference. I have of course turned the tablet off and back on. The Google Play Store doesn't seem to have registered that the app was uninstalled, and I don't know how to trigger that, and I have no idea what to do about the message I'm getting in the Google Play app itself on my tablet.

Does anyone know how I can resolve this and get my old apps reinstalled? Thanks!

  • android.stackexchange.com/questions/20777/… possible duplicate – Bo Lawson Dec 23 '18 at 0:47
  • 1
    Thanks, Bo Lawson. I actually had reviewed that post before putting up this post, and the methods there did not resolve the issue. But I was able to resolve it via another approach. – Matt Dec 23 '18 at 4:16
4

Google Support had me try a number of things that didn't help, but when they had me remove my payment methods, that seemed to do it. I had already removed and added my Google accounts from my device, which I didn't think would help because it clearly wasn't a problem specific to my device. (I had realized I also couldn't install that game or other games I'd bought to my phone, a separate device, so it wasn't device-specific.) The last thing I did was remove my payment methods and cancel a subscription in Google Play, and then I could install my apps to my tablet and phone. I'm not sure how that fixed it, but it did. It seemed to "reset" my devices with Google Play, so to speak. If anyone knows how that resolved the issue, I'd love to hear. I'm glad it worked, but I don't know why it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.