I tried to flash twrp image in POCO F1 by using the command fastboot flash recovery twrp.img. But it didn't work. It showed the error message:

fastboot FAILED (command write failed (Success))

What could be the possible reasons?


1 Answer 1


It can be one of the following issues:

1) Your TWRP image is corrupt. Try downloading the image again, or download from another source.

2.) There is an issue with your USB connection. Check your USB ports and the cable, or try another PC.

Also, are you using a Linux distribution? There is a known issue with Fastboot that sometimes causes the error you mentioned in Linux, so try a Windows PC if you can.

  • ya. I was using Linux distro, which was showing me this error. So I tried from a windows machine and it worked Commented Dec 24, 2018 at 11:20
  • FTR: In my case the connection was faulty. Type-C to Type-C cable was giving me this error; when I switched to Type-A-to-Type-C everything started working smoothly. Commented Aug 21, 2019 at 21:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .