1

I installed android file transfer and flashed the ROM of Google Nexus 2013 WIFI tablet by executing the flash-all script command on my macbook pro macOS Mojave. This tablet has issue with usb connection before and it will drop the USB connection after few minutes. I believe the usb connection disconnected while trying to write the firmware to the tablet. The dmesg shows the following now after the ROM flash failure

[44561.880936] usb 1-1-port2: Cannot enable. Maybe the USB cable is bad? [44562.790961] usb 1-1-port2: Cannot enable. Maybe the USB cable is bad? [44562.791046] usb 1-1-port2: unable to enumerate USB device

This is what i have tried so far

  1. Use different USB cables
  2. Create 51-android.rules file and then reboot

    pi@raspberrypi:~ $ cat /etc/udev/rules.d/51-android.rules SUBSYSTEM=="usb", ATTR{idVendor}=="18d1", ATTR{idProduct}=="4e41", MODE="0666", > OWNER=“pi” # MTP media (multimedia device) SUBSYSTEM=="usb", ATTR{idVendor}=="18d1", ATTR{idProduct}=="4e42", MODE="0666", > OWNER=“pi” # MTP media with USB debug on(multimedia device) SUBSYSTEM=="usb", ATTR{idVendor}=="18d1", ATTR{idProduct}=="4e43", MODE="0666", > OWNER=“pi” # PTP media (camera) SUBSYSTEM=="usb", ATTR{idVendor}=="18d1", ATTR{idProduct}=="4e44", MODE="0666", > OWNER=“pi” # PTP media with USB debug on (camera) SUBSYSTEM=="usb", ATTR{idVendor}=="18d1", ATTR{idProduct}=="4e40", MODE="0666", > OWNER=“pi” # Bootloader SUBSYSTEM=="usb", ATTR{idVendor}=="18d1", ATTR{idProduct}=="d001", MODE="0666", > OWNER=“pi” # Recovery

  3. lsusb did not show the google nexus devices

  4. Hard reset and factory reset the tablet
  5. Added product id into adb_usb.ini pi@raspberrypi:~ $ cat ~/.android/adb_usb.ini 0x18d1
  6. Took out cover and then disconnect the battery connection and then reconnect

I have done all the above using raspberry pi with raspbian OS. However, the raspberry pi is still not able to recognize my tablet.

I did the following on the Windows computer as well. I plugged in the device and checked the device manager application. It says that the device is unknown. I downloaded the driver from the internet and then try to update it through the device manager. Computer tells me that there is no driver installed while simultaneously saying that the driver is up to date. I believe I have enabled the USB debugging method before the ROM flash but the tablet seems to be completely out of OS now. I am just wondering whether anyone has solution to this?I have tried a lot of method with no avail

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.