I have used international roaming many times before with my one plus 5T and my native Vodafone India providers roaming plan. But this time I landed in Germany and it did not work.

I've been trying to debug and even on manual network selection most of the networks appear as "forbidden". Same networks used to latch on on earlier trips. My native Vodafone provider confirms that roaming is indeed active on my plan.

I tried to reboot, reinsert the Sim but nothing works.

One of the debug steps suggested involved steps in the Sim toolkit app. This app is somehow visible under apps but I cannot seem to find it anywhere. Ideas? How can I find where it is to use it.

Even in network settings the sin toolkit option does not seem there. Other users seem to have it there. I cleared my cache but no help.

Anything else I can try to fix this?

I am on Android 8.1.0 and oxygen is version 5.1.7

Any tips are very welcome! I'm stuck here in Germany with no connectivity and my providers help desk is pretty useless.

Eg. Would inserting the Sim into another device and then back into this one help? Are there roaming related settings that need to be pushed onto the Sim?

enter image description here

  • 1
    Sim Toolkit package is com.android.stk. If you cab check if it is installed (it should be installed) using the commands adb shell pm list packages | grep -n com.android,stk using a PC or pm list packages | grep -n com.android.stk via a terminal app. Dec 24, 2018 at 13:08
  • @Reddy: I added a screenshot. It shows that sim toolkit is installed. But how do I access it? Not showing up in my app list Dec 25, 2018 at 5:57
  • 1

3 Answers 3


I also faced the same problem with OnePlus5 mobile and with Vodafone IN. The local networks in Germany were showing as forbidden. The debug is to go to Sim Tool Kit -> International Roaming -> Select International from the options. Then try to manually search the network. This time also the networks may show up as forbidden, however click on the correct network and the settings will be completed automatically and you will be latched to International Roaming.

  • Glad it fixed the problem for you! In my case Sim Tool Kit itself is not visible. So could not try that. Sep 4, 2019 at 8:58

I had same problem with Airtel but in another country. But same SIM worked in same phone in some other countries. When I used to land in one particular country it won't latch to any network. I was having this problem for almost one year. I managed by inserting the SIM in a feature phone and it worked well. Finally I figured out what needs to be done to make it work in a smartphone. Please go to manual network selection and select your operator even if it shows as forbidden. It worked for me and might work for other also.

  • It disconnects after one minute
    – ronenfe
    Jan 16 at 9:28

In case it helps others here's how I fixed the issue: Take any other phone, maybe borrow one from a German local (I had a backup Moto G with me) and insert your SIM card in the new phone.

This action will somehow activate it. Then reinsert the SIM into the original One Plus 5T and magically everything works fine again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .