1

I'm using the NordVPN App for Android. The app version is 3.8.3. My Smartphone is a Honor 8X with Android 8.1.0 and EMUI 8.2.0.

In their "Automatic Kill Switch" article on https://nordvpn.com/features/kill-switch-technique/, they explain that: "At the moment Kill Switch technology is available only on Android 7 or later and has to be enabled in System Settings menu.".

If I navigate in my Smartphone to "Settings->Wireless & networks->VPN", I can see the NordVPN entry/profile, which has been created automatically by the NordVPN app.

However, I'm not able to set the "Always-on-VPN" option, because if I click on the NordVPN entry, it just opens the NordVPN app and not the settings of it in Android. Keep pressing it does not give me any option besides opening the app again.

If I create a dummy VPN entry and click it, I'm able to set the "Always-on-VPN" option because it opens the settings of it.

Is there any advice/known solution to this problem? Or is it impossible to access the entry, because it was created automatically by the NordVPN app and I have no control over it?

  • There's a Settings (gear) icon on the right side of all VPN entries (manual or those added by apps) at least on vanilla AOSP Oreo and Pie, not sure about customized ROMs such as yours. I'm able to successfully set "Block connections without VPN" so that routing table entries made for VPN are persistent across reboots and no traffic leaks. – Irfan Latif Dec 27 '18 at 7:09
  • I wrote a E-Mail to NordVPN and they replied, that the "Always-On-Feature" isn't available for Honor Devices(which is not right, you can choose this options for manually set up VPNs). The gear you describing isn't present in EMUI. Found a forum entry with the same problem here: forum.xda-developers.com/mediapad-m5/help/… Sadly no convinent solution there either. They suggest to use Settings Database Editor to enable the option. I will try that. But I'm not satisfied with this, I don't know if the expected behavier is garantied. – MaverinCode Dec 27 '18 at 16:07
  • You should post this as an answer if it works – janot Jan 17 at 21:26
  • No, editing the variable wasn't possible so this didn't work. – MaverinCode Mar 12 at 14:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.