Shortly ago, my J7 Prime stopped recognizing my fingerprint.

When I go to Settings -> Lock screen and security -> Fingerprint Scanner I get

An error has occurred with the fingerprint sensor. If this message appears repeatedly, restart your device.

I tried a few options I found, and none worked:

  1. Rebooting.
  2. Going into Safe Mode. The same error appears. Plus, almost all my widgets in the home screen disappeared, so I had to redo it.
  3. Settings -> Apps -> Three dots -> Show system apps -> Fingerprint -> Clear Data . The cache was already empty. Rebooting.
  4. Logging off and into my Samsung account.
  5. Developer options (this was already enabled) -> OEM unlock -> Enable. Reboot. Developer options -> OEM unlock -> Disable, and Developer options -> Disable.

What I did not (and I cannot) try:

  1. Rooting my phone (it is a corporate device).
  2. Resetting my phone (same).

What can I do to fix the problem? (other than taking it to the IT dept.)

3 Answers 3


Most likely the problem is with the fingerprint scanner itself. He was either damaged or moved away from the water, and he burned


There was a system update pending. After I updated the fingerprint sensor came back to life.

(Note: Not only that... about 1.5GB were freed, which I very much needed. Unfortunately, Android's gluttony will promptly take care of it.)

I cannot propose this as a general solution as:

  1. I am not sure it will always work (although after the update there were a few glitches that got fixed, so I guess there are chances it will work).
  2. This depends on the existence of a pending update, which will not always be available.
  • That's disturbing. Locking the fingerprint scanner to get you to update?
    – Ethan Z
    Mar 30, 2019 at 17:36
  • This didn't help me, seems like a problem with the finger print sensor itself. Aug 27, 2020 at 6:18

enter image description here

I Fixed this issue. I have Note 9 Phone.

You need to Remove and Reconnect your Battery.. I know its not Possible becouse Latest Phones Are Seeltype by itself.

But samsung give option for simmulate pull battry and reconnect. Its not lost any data.

Press Power button + Volume Down Button Same time and keep 30 Second

Then phone will be restart and try again your fingerprints.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .