1

I bought a new phone because my older was so old that Uber Driver was too slow, couldn't even use a different map service (like Google Maps or Waze). Bought a Redmi 6 (International Version), with Android 8.1.0 and MIUI Global 10.0.

So I installed Uber Driver, and to my surprise it crashed every time after the second screen of "what's new". I uninstalled it, and now after some two months I tried again. The problem persists. The first screens with instructions worked fine the first time (though the loud voice can't be turned off or lowered -- and the device volume is muted!). After these screens, came the "what's new" screens, and it crashed in the second. Now it just crashes before these screens, every time I try to open the app. The system is up to date. What can I do?

EDIT

Following @trishmapow comments, I managed to use adb logcat to create a log. The log file has 540 kB, and registered every information since the device was last turned on (I thought it would only register from the moment the command was issued). Should I upload this whole log somewhere? Should I extract only lines with some word in them?

  • 1
    Please share output of logcat. – trishmapow Dec 28 '18 at 1:57
  • 1
    This question might be better directed at the development team of the app... They'll have a much quicker solution than possibly modifying your device for compatibility.... Even if you change some settings ( most likely manually enabling permissions for the app in settings ) and everything works, I'm certain that such a large company would like to know of incompatibility problems especially a full crash, It'd be extremely helpful for them to supply the logcat and your specific device model... They can't test an app on every device in the world, so it'd be great to help them out with your test. – Zillinium Dec 28 '18 at 4:29
  • @trishmapow Thank you, I'm trying. No success yet, though. – Rodrigo Dec 28 '18 at 5:15
  • @Zillinium I've sent an email to the address given here. Soon after I got the reply "We're sorry. You’ve contacted an address that does not accept incoming email (...) Please submit your request by tapping “Help” in the Uber app [impossible!] or by visiting help.uber.com from a web browser. There you’ll find answers to frequently asked questions and have the option to submit a support request." This last option, however, is nowhere to be seen. Great, huh? I'll try calling them tomorrow. Thank you! – Rodrigo Dec 28 '18 at 5:21
  • Have you tried to enable the permissions using the system app ? ... I've seen many apps crash on 8.1 because of the way it handles permissions, usually the developer needs to implement the new permission system to ask for permission acceptance... If it's designed for or targeted toward older model 5.1 for example, it doesn't need to ask for permission acceptance.... The workaround is to manually enable the permissions using the settings app, then try opening it again ( sometimes clear data and then reopen it ) ... My guess is that after the What's New screen, the app is requesting GPS Perm's – Zillinium Dec 28 '18 at 5:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.