I have a HTC Desire HD that up until recently has been running well with a custom ROM. For some reason, the phone started to "misbehave" in a number of ways after about 10 months of painless operation, so I decide to try and put the LeeDroid ROM on the phone. End result, the phone is now not much better than a basic iPod touch.

My mobile network settings are all greyed out, and the phone is telling me that it no longer knows what its IMEI, IMEI SV, IMSI, Phone Number, and Base Band details are. Every other feature of the phone seems to be working OK, just not the mobile network connectivity.

Yes, it's a very sad little brick indeed, and I now find myself going retro and using my old Sony Ericson Walkman phone which is SO old school that it's not funny! Yes, it looks really pathetic when I go to touch the screen and... well, you get the picture! LOL

I am still hopeful that someone out there might know how I can restore the missing information. I have most of what I need documented, but no idea if there is a way to locate and restore the data more directly from the phone, or if there is a tool that will allow me to feed the missing values in (remember, these are meant to be unique identifiers) in order to help me to restore the phone in some way.

No amount of master resetting, or alternative ROM installing has been of any help so far, and asking this question is really a last gasp attempt to try and de-brick the mobile features of the phone before I find myself either buying an expensive repair at the local authorized repairer, or buying an expensive replacement phone.

Serious KUDOS to anyone who might have an answer to this.

  • Have you tried reflashing the Radio ROM?
    – mcchots
    Commented Mar 14, 2012 at 8:42
  • 1
    Did you try flashing stock? Commented Mar 14, 2012 at 15:42
  • The Radio ROM is different from the OS ROM.
    – mcchots
    Commented Mar 15, 2012 at 9:28
  • 1
    Carrying on from above. As the name suggests, it controls the radio part of the phone. You can use the same Radio ROM with different OS ROM's but sometimes there are incompatibilities. I suggest searching for a stable Radio ROM that works with a OS ROM that worked for you and flash them both.
    – mcchots
    Commented Mar 15, 2012 at 9:38
  • Had the same issue with galaxy s I91000, fix by installing stock ROM for corresponding device. you should try flashing the ROM specific to Country/operator.. and search DesireHD section on XDA.. its common problem when efs files are not backup
    – user12295
    Commented Mar 15, 2012 at 11:59

1 Answer 1


Problem solved, and I think I'm finally getting a handle on all of this after several hours of some serious digging through the interwebz, and a bit of trial and error. So here is what I ended up doing, step by step:

  1. Locate a stock ROM as suggested by Matthew Read and user12295.
    • This was possibly the hardest part as there were so many dead links out there, and I ended up using a link I found to the Shipped Roms website.
  2. I elected to download the file labelled RUU_Ace_Gingerbread_S_HTC_WWE_2.50.405.2_Radio_12.54.60.25_26.09.04.11_M2_release_199042_signed.exe.
  3. Fully charged the battery on the phone.
  4. Located the original HTC cable in a fit of paranoia and connect my phone to my laptop using a USB2.0 port.
    • For some weird reason the USB3.0 on my particular laptop wouldn't let me connect the phone during the flashing process the first time I tried to do this.
  5. Ran the RUU utility that I had downloaded, crossed my fingers, and waited for the phone to be wiped and flashed after navigating the various screens of the RUU.
  6. Saw my phone go through a reboot at the end of the process... and all connectivity was working with full networking/identity data restored.

So it turns out that the IMEI number is flashed to a different bit of the phone's internal memory, and the stock flash somehow picks this up.

So All systems go, but I miss many of the features of the phone, including the better battery life that I had under a better ROM and because a couple of my own experimental apps will no longer work. All of a sudden I wish I'd downloaded the 1.72 version of the RUU as it seems I need to go through a downgrade process in order to root the phone and get a custom ROM reinstalled.

After a bit more Interwebz digging, I came across an application called Ultimate Multi Tool, and I worked through the following procedure:

  1. Connected phone to laptop (as per earlier process)
  2. Set phone to charge only
  3. On the phone, enabled Settings -> Applications -> Unknown Sources
  4. On the phone, enabled Settings -> Applications -> Development -> USB Debugging
  5. Ran the Ultimate Multi Tool
  6. Operations -> TempRoot
  7. Operations -> Gold Card.
    • Clicked on the CID button to get the id for my SD-Card.
    • Clicked on the "Free HTC goldcard generator" link and filled out the form on the screen to generate a goldcard image.
    • Clicked on the Load goldcard.img button and located the goldcard.img file
    • Clicked on the Create GoldCard button.
  8. Operations -> Downgrade.
    • I needed to locate a file called PD98IMG.zip before I could begin the downgrade process. The downgrade process was VERY slow. Took about 30 minutes for me, but your time may vary. As an afterthought, simply applying an earlier RUU may have been a better approach, but I thought I should document exactly what I did.
    • Phone rebooted into HBOOT menu, and I simply followed instructions on PC and phone screens.
    • Waited for downgrade to complete and rebooted phone.
  9. Repeat steps 2, 3, 4, & 5
  10. Used On Screen buttons to push Visionary+ and SuperUser to the phone.
  11. On the phone, Ran Visionary+
    • Checked the Set System r/w after root checkbox
    • Selected Temproot now
    • After process finished, Selected Permroot now
    • Superuser asks for permissions, so pressed the Allow button
    • Phone Reboots
  12. Set phone to charge only once it had finished rebooting completely
  13. Back to Ultimate Multi Tool, and selected File -> Check S-Off/CID/SIM
    • Superuser asks for permissions, so pressed the Allow button
    • Tool now reports back that the CID is a whole bunch of 1's, phone is S-OFF, and SIM Unlocked. :-)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .