In my Android phone when I go to Settings -> Language and Keyboard Settings -> Select Language I see "Locale" as the title on the top row and see that only few languages are listed. I suspect its because of this "Locale" setting.

Where I can change it so that all supported languages will be listed? Under Settings -> Language & Keyboard I don't see a "Locale" option.

  • 3
    What phone do you have and what version of Android is it runnning? That may well affect the answers.
    – GAThrawn
    Mar 14, 2012 at 14:37
  • I don't think "Locale" is a separate setting anywhere. It just looks like the list title/header to me. This also sounds like it may be a duplicate of How do I add a new language? Mar 14, 2012 at 17:47
  • android version is 2.3.5 . Does the language list depend on teh android version or is it divide by the mobile manufacturer
    – preetha
    Mar 15, 2012 at 5:59

2 Answers 2


The keyboard settings shows all supported languages no matter the locale of the device, so if a language is not listed than it's not supported. A good alternative is AnysoftKeyboard; you can download language packs for it.


If you want to change locale settings on your device, the Set Locale and Language app1 might prove helpful as well. Locale-Einstellung looks almost the same. MoreLocale 22 might offer an alternative, as it also allows to create custom locales -- which is also supported by Custom Locale3.

Set Locale MoreLocale2 Custom Locale

With Any Locale4 switching the locale can be as easy as tapping a widget -- as it is with LocaleSwitch5 or the Language Picker Widget6.

Any Locale LocaleSwitch Language Picker

Also very nice: Raygional7. And there are probably many more to chose from...


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .