0

I have a RCA device running Android 7.1.2. I'm having difficulty unlocking the bootloader.

On my device I've an option to turn on OEM Unlocking. When I try it asks if I want to enable when I select Enable it just jumps back to off position.

This is what I have tried. adb reboot fastboot The device reboots and stays on the splash screen when I do fastboot devices it shows "0123456789 fastboot". This seems weird to me I expected to see the S/N number like I see when I do adb devices. Then I tried "fastboot flashing unlock" I don't see any change on the device and I instantly get FAILED.

Fastboot Unlocking

How can I get the bootloader unlocked?

I have seen people that have gotten it unlocked, but they were on a previous version of Android.

My tablets info:

  • Model: RCT6973W43R
  • Android Version: 7.1.2
  • Android Security Patch: October 1, 2018
  • Kernel Version: 3.10.104 Fri Oct 19 11:05:52 CST 2018
  • Build number: RCT6973W43R-ANDROID7.1-V38-V1.16.132-DS-E17
  • Rockship: RK3066
2

Enable OEM Unlocking If your devices manufacturer allows OEM unlocking
A.K.A (Also Known As) "Bootloader Unlocking".

DevOpt

OEMUnlock

Enable Unlock

After Enabling OEM Unlocking

  • Reboot to Fastboot

    ADB

    • adb reboot bootloader
  • OEM Unlock

    • fastboot oem unlock
      or
      fastboot oem unlock -go
      or
      fastboot oem unlock /path/to/unlock-token.bin

If you have an MTK CPU you might be interested in flashing image's using a scatter file and SP Flash Tool v5.16 or above, as it doesn't require an unlocked bootloader.

  • Thanks for your quick reply. As mentioned in my question I already tried to enable the OEM Unlocking in the Developer Options. When I try it just slides right back to the off position. – Sruly Jan 3 at 11:41
  • 1
    You've had a Kernel update alongside the system update... I'm fairly sure that the new kernel locks out modifications and bootloader unlocking. ... As it has an Intel CPU you can use androidmtk.com/flash-stock-rom-using-intel-phone-flash-tool ... Try looking around and getting familiar with stock firmware flashing on your device... This is using USB access to the CPU and bypasses androids security regarding bootloader unlocking... same for MTK CPUs etc... – Gadget Guru Jan 4 at 2:50
  • Can you advise me where I can get more info on this flashing I wasn't successful or at least I'm not sure what I'm looking for. – Sruly Jan 8 at 19:11
  • I searched Intel ( Your CPU ) Firmware flashing, and it gave me that software, ... this tells me that you can access your system via the CPU in a "PreBoot" state, bypassing the System protection features... It's the same for MTK Mediatek CPU's, I'm more familiar with MTKs. – Gadget Guru Jan 9 at 12:51
  • I have used the Wwr Tool in the past for getting the ROM on a MTK device. I had a tutorial from Hovatek Forums that helped me (forum.hovatek.com/thread-21970.html). Would you know if there is any similar tutorial or at least some guide for a similar thing for the Intel chipset? – Sruly Jan 9 at 20:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.