I'm using a custom ROM for ICS on my Samsung Galaxy S.

I like being able to create a new line in a text message, but the 'enter' key on all keyboards I use (though primarily Swype) is replaced with a 'smiley' key.

Is there any way to change this behaviour? Some research shows me it's to do with the field type used in the messaging app. Can the MMS.apk package be modified to use a different field type, or is it possible to modify Swype so that the 'enter' key is used instead?

I'm aware that I could use a 3rd party messaging app, but I like the stock app. I know some people are happy to send multiple messages in bursts rather than a long message with new lines but I'd find that annoying to receive and I don't want to annoy people I text.

  • Up to at least Android 2.3 this wasn't possible in the vanilla messaging app (came up here: Is it possible to remove the “:-)” smiley key in Swype for stock Messaging?). It may not be possible still, unfortunately. Commented Mar 14, 2012 at 13:52
  • Thanks, I saw that question but it looked to be more of a Swype question - they were asking about resizing the backspace key rather than converting it to an enter key. In CyanogenMod 7 (and below) the stock messaging app was tweaked with an option in settings that toggled the input field type so that the smiley key would become an enter key. I was hoping for something similar. Commented Mar 14, 2012 at 14:59

6 Answers 6


Ok, so after looking into this a bit more I managed to get somewhere.

I pulled the Mms.apk file from /system/app and decompiled it with APK Multi-Tool. Then I started editing the file /res/layout/compose_message_activity.xml.

It has an tag towards the bottom of the file. I removed textShortMessage from android:inputType on this line. This means:




This worked for me in that the smiley key is replaced with the enter key after recompiling, signing and pushing back to my phone. My problem is that the enter key sends the message rather than inserting a new line.

After more Googling I came across this thread on XDA. This Mms.apk works exactly how I want it to - no smiley key and the enter key adds a new line. It's also black themed which I prefer for my screen.

I decompiled the newly found black Mms.apk file from XDA to try and find what they guy did to make the enter button actually add a new line, but I can't see what's different.

I'd still like to know how to do this if anybody knows - this was my first time playing with a decompiled APK so I don't really know what I'm doing. For now though I'm quite happy with my new black themed Mms.apk app.

  • Have you tried using Shift + Enter to add a new line?
    – SaintWacko
    Commented Mar 15, 2012 at 23:01

I have a custom (Baked) Jelly Bean 4.2.2 ROM on a HTC One S and Swype 1.4 installed. I was ready to go on a shooting spree when I thought I couldn't hit a return button to start a new line!

I opened a SMS thread, tapped Menu > Settings and scrolled all the way down. There is an option at the bottom called Soft keyboard type. Open that and you get --

<> Smiley key

<> Send

<> Enter for a new line

Select the bottom one and you're golden!

This setting will change it for both the stock Android keyboard and Swype.



If you go into the settings of the stock mms app, there is a setting to have the enter key instead of the smiley key


This post is about a bit old now, but I guess, since I also faced the same issue, I should share the solutions I found.

Before KitKat, the Messaging app had an option in its Settings to either use smiley key or a newline key. However, after the KitKat update, there is no such option. Instead, we can access the newline key in some other way. Actually, when you press the capitalisation key to switch all the characters to uppercase letters, the smiley key also switches to the newline key. There it is! It's not gone, just hidden.


There is a way to fix the issue GO to sms setting > click "soft keyboard type and select "show the emoticons key"" Then go to swift key settings and select Enter key option

It works for me all the time.


On my phone, I changed character support to "Reduced" in messaging settings and the return key returned.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .