2

I'm trying to unlock my HTC U11 and I've tried to run fastboot both from the packages of my Ubuntu derivative (fastboot version 1:7.0.0+r33-2) and from the platform tools (fastboot version 28.0.1-4986621).

I can see my device both with adb in normal operation and with fastboot devices in download mode.

The output of fastboot getvar all is:

(bootloader) kernel: lk
(bootloader) product: htc_ocndugl
(bootloader) version: 1.0
(bootloader) max-download-size: 1562400000
(bootloader) serialno: xxx
(bootloader) slot-count: 0
(bootloader) current-slot:
(bootloader) imei: xxx
(bootloader) version-main: 1.27.401.11
(bootloader) boot-mode: download
(bootloader) version-baseband: xxx
(bootloader) version-bootloader: 1.0.0.0000
(bootloader) mid: 2PZC30000
(bootloader) cid: HTC__034
all:
finished. total time: 0.005s

When I try to get a token in order to unlock the phone, the command doesn't complete within any reasonable amount of time, e.g., fastboot oem get_identifier_token did not complete after hours and I unplugged the phone:

...
(bootloader) [KillSwitch] : /dev/block/bootdevice/by-name/frp
(bootloader) [KillSwitch] Last Byte is 0X01, enable unlock
FAILED (status read failed (No such device))
finished. total time: 23223.012s

Has anyone seen this or can give me any pointers as to what I'm doing wrong?

0

I tried the same process from a different laptop and it worked instantly. I don't know what the cause of this issue is but having the alternative solution, I don't feel like investigating any longer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.