0

I'm using a local branded chinese phone. And my phones comes with locked bootloader. As it is a local branded phone, manufacture doesn't provide a official way to unlock it! I've tried many way I found in Google. but non of them work. It always ended up like the picture. Can anyone help me unlocking my phones bootloader? Result always shows like this

  • 1
    Does it have an MTK (Mediatek) chipset? They are often supported by SP Flash Tools as fastboot commands don't work with them for some reason (may be they don't support that protocol). Try that tool and flash the images you want (be careful; take backup beforehand; always flash compatible images). – Firelord Jan 5 at 18:03
  • Yes, it's mt6580 chipset. And I've already tried to flash TWRP using SP Flash Tool, but it always shows some error. – Sabbir Ahamed Jan 6 at 9:26
  • @Firelord i'm getting "BROM ERROR: S_BROM_DOWNLOAD_DA_FAIL (2004)" error. Any idea how can i fix this?? – Sabbir Ahamed Jan 6 at 17:14
  • are you using the correct scatter file? – Reddy Lutonadio Jan 6 at 17:35
  • Yes. Every img file in my stock rom(boot, cache, system erc) was signed. So I needed to unsign recovery.img in order to port TWRP. And now when I'm putting the TWRP in my stock rom folder and trying to flash it via SP Flash Tool, there is a new error poping up. It says, 'ERROR: S_SECURITY_SECURE_USB_DL_IMAGE_SIGN_HEADER_NOT_FOUND (6045), MSP ERROR CODE: 0×00' I tried to edit Checksum.ini and also deleted it. But nothing works! – Sabbir Ahamed Jan 7 at 3:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.