2

I am trying to connect to a tablet with Android Studio. The tablet is a Fusion5 Tablet F704B. It's a low cost tablet with Oreo 8.1 OS. I only have this tablet connected to my PC. Android Studio does show 1 connected device, but it is labeled only as "Unknown"

enter image description here

When I hit the run app button in Android Studio, the gradle builds fine and then I see a "Error Installing APK"

enter image description here

I do more debug and run "adb devices" I see:

enter image description here

Note: On the tablet, I do have developer mode enabled and have USB Debugging enabled. I have tried USB Configuration to Charging, MTP, PTP, and USB Ethernet and nothing allowed allowed adb devices to see the tablet serial number. I have also tried Multiple USB cables to connect the tablet, and that did allow the tablet serial number to be shown. I have also connected other tablets I own, and they all show a serial number correctly. I can run my app via android studio on 4 other tablets that I own. Just not on this Fusion5 tablet.

I believe the lack of a serial number in this Fusion5 tablet is causing my issue with Android Studio. After some research, I found that the serial number is contained in the tablet OS at /sys/class/android_usb/android0/iSerial. This file needs root access to edit. Using "adb shell", I can navigate to the directory, but can't view the file contents without root access. I believe the file is has no content. I believe this because the value iSerial shows as blank when I do a "lsusb -v" on my computer.

I have spent many hours researching how to give my tablet root access, but the first step involves loading the TWRP recovery image. The twrp recovery images exist for many phones/tablets, but not for this odd offbrand cheap tablet.

I have also tried to bypass TWRP and perform an adp sideload , but fails with the default recovery routine that comes with my tablet.

Does anyone know of a way to edit the serial number field without root access?
Or is there some other clever way to get me root access I am missing?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.