2

What I have tried:

  1. I have tried USB earphones and mic, both works perfectly, So it should not be Sound/Audio issue in Android.

  2. If I keep earphones plugged in during boot, PC shuts down at "Initializing" Step. So I think it's a kernel issue. But there is no stacktrace in last_kmsg.

  3. I have tried logcat and bugreport to get some information about this. Logcat has no error or even output between inserting jack and System crash.Bugreport have too much information and I am not able to find anything about crash.

  4. /proc/last_kmsg doesn't exist. /dev/kmsg has output regarding other usb devices/apps. But, it fails to show/save anything in the output after connecting jack. It just shuts down.

  5. It is not a hardware issue, because both windows 8.1 and xubuntu 18.04 are running without any mic/audio problem in same laptop.

UPDATE 1: It is now confirm that the issue is in android 7.1.1 x86 build, Specificaly with kernel. I tried Default Androidx86 7.1.1 build, redmi os, prmieos. All are based on 7.1.1 (nougat) and had this bug. But Android x86 8.1 oreo builds seems to have resolved this bug. Now, I need to wait for phoenix os to upgrade. One thing i tried is to replace the phoenix nougat kernel with android orea kernel and it booted fine, but no drivers compatibility. Graphics, audio wifi didn't work. I need to replace files too, but i have no idea which one.

People on XDA forums has done it, But I couldn't achieve that possibly because I don't have that much Knowledge about this.

How can I succesfully update kernel and drivers?

  • You only considered software problems, may be it is a hardware problem (static discharge causing reset)? As we are talking about an x86 system try to boot a live CD like Linux and test your headphones again. – Robert Jan 8 at 18:39
  • No, I am runninng Windows 8.1, Ubuntu 18.04 in same laptop and It works flawlessly in both OS. I think it might be a driver issue. I have tried Default Androidx86, Remix OS, Prime OS other than this. They all had boot/grub issues which I couldn't resolve. I should have added that in question itself. – Sonu Panchal Jan 8 at 20:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.