1

How can I delete a file with special characters from an un-rooted Android device?

I used a web site to download a YouTube video to my mobile phone. The video name contained special characters (emoticons and alike) and the Android browser downloaded the file right away, so I could not rename it.

Now I'm stuck with a file that I cannot delete with the stock file manager of my phone. It is a Wiko device with some shady file manager app. I also tried AndroZip, which is usually more reliable.

However, the file has a size of 0 bytes and I can neither delete, nor rename or move it. I do not get any error message, simply nothing happens. In AndroZip the file does not even show up, so I'm not sure whether the Wiko app cached the file name somewhere and, in fact, it does no longer exist, or if AndroZip cannot display the file due to the special character, even though it exists.

Long story short: The device is not rooted and I want to get rid of that broken file. What can I do without resetting or rooting the entire device? Is there any helpful app that can handle special characters? Is there any safe mode option that would be of use?

1

I converted the file into a 240p MP4, downloaded it using Chrome, and I was able to delete the file using Solid Explorer easily.

I was also able to delete it using Termux. I installed it, enabled Storage permission for it from Settings app, launched it, and used these commands:

cd /sdcard/Download/   #I had downloaded it in Download folder.
rm FILE_NAME           # to type file name, I didn't actually type it. I used Hacker's Keyboard which comes with Tab key for auto-completion. I typed JER and pressed tab key to automatically load the full file name including emoji (which actually renders as a flame in Termux). 

If you wish to keep your default keyboard, Termux provides two more means to use Tab autocompletion. Either use Volume Up + T to send a Tab to the shell, or use Volume Up + Q to display an additional button row on top of your keyboard, which contains frequently used commands such as Esc, Ctrl, Alt and Tab itself.

  • Does Termux require rooting? It looks really promising, if it doesn't. I'll check it out, as soon as I'm home. – user1438038 Jan 8 at 16:53
  • @user1438038 no, Termux doesn't require root access. Just make sure to give storage permission first before using it and also try Hacker's keyboard or you might not be able to type the full file name at all. – Firelord Jan 8 at 16:56
  • 1
    Worked like a charm. Using Termux, I could easily delete the file. There was no need to enter the entire file name, I simply used the wildcard operator *. – user1438038 Jan 9 at 8:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.