4

Recently I've been getting an issue that when I start any download from an app such as the Play Store or Google drive, when I click the download button I get a indication that the download has begun but the actual download starts minutes after the button has been pressed. For example, if I try to download a file from Google Drive I get the snack bar stating "File will be downloaded, check notifications for details" but the actual download starts after a few minutes. The Play Store starts downloads after a few minutes in which the notification indicates that the download is complete, but when I go into the Play Store's Installed tab the app download is stuck at around 25%. I haven't faced a problem like that before. Chrome downloads are working fine.

Things I've tried,

1) Deleting cache and data of Play Store, Drive and Downloads app.

2) Uninstalled updates of the above apps.

3) Wiped Cache from Recovery.

4) Tried downloading from Safe Mode.

5) Did a factory reset.

Specs:

Model: OnePlus 3

Android Version: 8.0.0

OxygenOS Version: 5.0.8

Any help regarding this would be great!

  • A logcat would help in this situation. You can do it through an app from the play store like matlog. Another option is from a computer with adb. Just open an elevated terminal and throw the commanf: linux: adb logcat -v long > ~/Desktop/logcat.txt ---------- windows: adb logcat -v long > %userprofile%\desktop\logcat.txt ---------- this will put a logcat.txt on your desktop. Then just paste it to a site like pastebin or whatever then link it to here or your post. – Bo Lawson Jan 15 at 8:24
  • I've pasted a snippet of the log when I initiated a drive download. pastebin.com/QBYhSrtP – C4L1BER Jan 15 at 11:22
  • Things definitely are not going smoothly, the download is getting quewed starting the process before it gets its mojo it stops, cleans ups after itself, and restarts, the downloadmanager is lost thinking the path is invalid then goes ahead and adds a new path then continues on Just to add to things there is also a http 404 within there. This more than understandably is creating the lag you are experiencing. I have a good idea of what's going on. There is also a lot of possibly helpful information being suppressed within the log due to so much going on and the apps being so chatty. – Bo Lawson Jan 16 at 3:31
  • I am a huge fan of logcats but I will limit my request to just hopefully two more. It would be super helpful by giving a bit more insight into the issue. First, one will white-list a process to not be suppressed and blacklist a process to not interfere. ----- adb logcat -P '"/10061 20968 ~/10141 22612"' ------ if your device is rooted this one is helpful: --- dumpsys activity broadcasts – Bo Lawson Jan 16 at 3:37
  • Sorry for being a little uninformed, but when I try to enter this command ----- adb logcat -P '"/10061 20968 ~/10141 22612"' ------ the terminal appears to be accepting the command but I get no output. And when I try to print the log to a file it comes as empty. – C4L1BER Jan 16 at 6:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.