3

How can I install google play on the Android SDK Emulator? I start my emulator like this:

./emulator -avd my_custom_device_API_26 -dns-server 8.8.8.8 -writable-system 

and I tried it How to install Google Play services on an Android 6.0 emulator?, but it doesn't work. Although I'm staring emulator as writable, I get:

remote couldn't create file: Read-only file system

Also, I've bit different APKs as mentioned in that answer namely: PrebuiltGmsCorePix.apk instead GmsCore.apk and I can't find GoogleLoginService.apk. I have the Open GApps 8.1 Pico version. I've also tried to install APKs but was unsuccessful.

1
  • You need to elevate to root access to mount RW. Try adb root then adb remount then push and install your package.
    – Bo Lawson
    Jan 18, 2019 at 13:45

3 Answers 3

5

For that, you have to install the Google Play image from the Android Studio SDK Manager. But you can't get it for API level below 24

1

Remember that to display all those submenus you have to tick Show Package Details on Android SDK setting:

enter image description here

Also the download may be about 2GB but on hard drive may take 10GB once decompressed.

1

Other comments don't mention it, but after installing the Google Play you also need to create an emulator again (there will be +Store in the description) enter image description here

1
  • 1
    Hiya! Make sure when answering that you're still giving a full solution to the question being asked. For situations like this, it's common to point to other answers as what to follow for a setup, then continue with the extra details you feel are necessary.
    – Ethan Z
    Nov 24, 2021 at 18:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .