0

my rom freezes a few seconds after it booted up, the screen gets black, then it turns off and there is nothing i can do but reboot. before it freezes it says com.android.bluetooth stopped. perhaps it has something 2 do with it.

im on: crDroidAndroid-8.1-20180926-riva-v4.6.1

recovery: OrangeFox-R8.3-riva

i tried several roms, recoveries and the inferno kernel but same problem. no problem with stock rom.

i got some logs:

logcat (not the complete log): logcat

dmesg: kernel boot log

the new last_kmsg are empty but i have old ones. i can post them if u think they r important. and i have a tombstone log for bluetooth. buts its 2 big 2 post at pastebin ;D i can do it if its important.

sum1 has a hint for me?

cheers

  • 1
    This should be reported to the respective ROM threads instead. – Andy Yan Jan 19 at 3:18
  • forum.xda-developers.com/xiaomi-redmi-5a/development, here you have other rom's available for your device. select official one's which have more number of posts and discussions (bcz the developer will be active by solving bugs reported by users) – Rahul Gopi Jan 19 at 6:05
  • did u read that this problem is not related to one custom rom? this problem occurs on every custom rom i tried. so its not a rom only problem. i could report it to every custom rom thread ;D i wont do this and i asked at the redmi 5a thread. they couldnt help me yet so i try it here ;> – morturio Jan 19 at 10:25
  • i forgot 2 mention: it once worked. but then i flashed a newer version of crdroid. since then no custom rom works :/ i thought it could b a hardware issue but the stock rom works... dunno – morturio Jan 19 at 10:35
  • @morturio it is definitely an issue related to the custom ROM('s) source code. Based on your logs it looks like the vendor blobs need to be updated more details would confirm it. Have all the roms you tried been higher then your devices base firmware of android 7.1.2 or all been android 8.x. Have you tried a custom rom of android version 7.1.2 and had bluetooth issue. Most likely the ROM's you tried all use the same proprietary vendor source in their manifest. – Bo Lawson Jan 19 at 16:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.