4

I want to use my Filco Convertible 2 TKL keyboard with swedish layout on my Samsung S8, but cannot get any other layout than US. I want Swedish.

The other questions I could find in here did not help.

Here is my Settings menu for physical keyboard: physical keyboard menu

I've also seen the Swiftkey help and tried their suggestion, to no av. Their input menu shows nothing related to layout, beside a link to the Android options.

As you can see I have four input there, three stock android languages, and Swiftkey. I've tried both the stock swedish, and Swiftkey in swedish. The shortcut menu says that switching language is done with shift+enter. That does nothing more than putting an actual space in my text.


Edit: I've now removed the stock keyboards from the non physical keyboard, and they also disappeared from the physical keyboard menu (which is strange, but ok). I now have nothing more than Swiftkey, both for on-screen and physical keyboards. In Swedish. Still, the physical keyboard writes with US layout.

5
  • 1
    You could try External Keyboard Helper (it also has a gratis demo to try out, though that hasn't been updated for a while).
    – Izzy
    Jan 20, 2019 at 22:21
  • @Izzy thanks! It didn't help though. I've got the app, it's high up in the "Physical keyboard" settings menu, in Swedish. Still US layout. One thing is the "Language and input"->"Default keyboard": it's stuck on SwiftKey. I also see the External Keyboard Helper, and Samsung keyboard as alternatives, but these are not selectable.
    – Gauthier
    Jan 23, 2019 at 14:04
  • Sad to hear it didn't help (but at least was worth a try). But glad to see you solved your issue, congrats! And that without needing an extra app. All the better!
    – Izzy
    Jan 23, 2019 at 23:01
  • External Keyboard Helper did the trick for me. I know this thread is old, but next time, post screenshots, how you configured External Keyboard Helper. Why don't you put "Swedish" for all the keyboards?
    – Quidam
    May 5, 2020 at 18:47
  • @Quidam I want the auto-complete in all three languages.
    – Gauthier
    May 30, 2020 at 15:30

1 Answer 1

3

The solution involved deactivating all keyboards from the on-screen keyboard options.

After doing so, the only one that was left (as on-screen) was also the only one left in physical. Even SwiftKey Swedish (not External keyboard helper) now works.

With several possible keyboards in on-screen, I still cannot select which one is default (the options show up with radio buttons, but are not selectable), but I think I can live with it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .