6

I have a Huawei nova 3i and I remember unlocking developer options when I first got the phone a few months back. Problem is now I have noticed that the developer options are gone so I went to build number and went to press it 7 times but after the first press it says (you are already a developer) but the option is still not there. I have looked online for at least an hour but can find nothing. Any help would be appreciated thanks

5
  • Did you try to make a reboot and look again if its activated? Jan 20, 2019 at 22:13
  • I just tried a restart but still nothing?
    – Daniel
    Jan 20, 2019 at 22:26
  • Not sure if it matters but I'm using android 8.1.0
    – Daniel
    Jan 20, 2019 at 22:32
  • I am not sure but I remember that I have read something about Huwei has moved the developer menu somewhere else in the settings. Check all the settings (sub-)menus for the developer options.
    – Robert
    Jan 21, 2019 at 13:31
  • @Robert thanks but I unlocked the option when I first got the phone and it was in the system menu 3rd from the bottom but it is gone now.
    – Daniel
    Jan 21, 2019 at 20:03

5 Answers 5

4

If the Developer options menu refuses to appear there is an alternative:

Use the very tiny app Developer Options. It allows you to enter the developer options menu independently if you have enabled or disabled it.

Once you are seeing the developer options menu check the switch on the top for enabling/disabling the developer options. Try to toggle it several times and in the end leave it enabled. Now check if the developer options menu is visible.

If this does not work use the app again to enter the developer options menu and change the developer options switch to disabled. Then try to tap again the build number 7 times. Hopefully afterwards the developer options menu appears. If not you can keep the "Developer Options" app as workaround. In difference to other apps it does not contains tracking, adware or advertisement frameworks (at least the version I have checked - v1.0.4).

5
  • Well you got me worried for a minute Robert because I just got the app and when I selected it part of my phone froze up I couldn't swipe left or right from the main screen and thought the app was bad. But I could still access the drop down menu so I checked settings and developer options were still not there and main screen was still stuck but I could access the back, home and app buttons at the bottom of screen and I pressed the app button and then I could close the app by swiping right but I could not select it. When I did press the app before swiping it away it would freeze that section
    – Daniel
    Jan 21, 2019 at 20:41
  • And I would need to press the app (square) button again to unfreeze screen
    – Daniel
    Jan 21, 2019 at 20:42
  • I finally found the other question I had in mind th is nearly identically to your question. It has a slightly different solution, may be it works: android.stackexchange.com/a/205858/2241
    – Robert
    Jan 21, 2019 at 20:45
  • Well I'm about ready to give up mate i got that app and followed instructions but there was only one developer options selection and instructions said there were two but before that there was a selection called developer mode, I tried dev options first which was
    – Daniel
    Jan 21, 2019 at 21:17
  • Com.android.settings.development.DevelopmentsettingDisabledActivity Instead of com.android.settings.Settings$DeveloperSettingsActivity Which the guys said was the first out of 2 dev options it did nothing and I checked to see if dev options were there but no. Then I pressed dev mode option and it took me to and screen that said {.} developer mode and had a toggle which I turned to on and then checked but still no dev options
    – Daniel
    Jan 21, 2019 at 21:18
4

For me it was inside System menu.

Settings--> System --> Advanced --> Developer Options.

For Enabling Developer Option:

Settings--> About Phone --> Build Number (Tap 7 Times, to enable)

Tested on Moto Action.

1
  • same for me on Sony Xperia XZ2, Android 10
    – user829755
    Jan 6, 2021 at 12:41
3

I had the same exact problem with the mentioned phone and none of the provided solutions worked for me. Finally i succeeded to make the developer options visible by going to settings - apps - selecting "settings" app and executing "clear data" on it. It worked with me.

1
  • 2
    Thanks Johny but after a lot of things I ended up giving up and then when I updated to android 9 I was able to get developer options back the normal. After the update the first thing I did was press build number 7 times and it worked so I'm all good now but thank you for help maybe someone else who has same issue but doesn't want android 9 can try you way 👍
    – Daniel
    Mar 27, 2019 at 22:23
1

Just press the build number a few times and then go the settings->system

Honor with EMUI 9.1.0 and Android 9

1
  • This could also be the solution, especially when the device upgraded to a newer OS/version. And on recent OEM OSes, the Developer options is hidden in additional/advanced settings. May 30 at 10:15
0

I had the same problem on my sm-j600g but I rebooted and showed up by itself

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .