0

As the title says, one single game on the app store that I had installed beforehand without issues, now refuses to install at all. The playstore keeps giving me error -506 over and over, and that's when it installs the game, it downloads the game as it should but does not get past the installing stage because it keeps tossing error -506. Googling didn't help either because googling it only gives me topics about other error codes that are not related to mine at all. Please, if anyone knows the solution or possible fixes to this, suggest them to me here so I can finally play the game again.

0

Possibly the error is because you have got a dead data directory corpse somewhere from that one specific app from a previous install of the app. Once you uninstalled it it did not clean up after its self properly. You can try adb to get the remnants of the app with the command:

adb uninstall (package_name)

Looking like:

adb uninstall com.one.specificAPK

If that does not work and you have rooted privledges then use a root explorer and navigate to /data/data/ once there look for that one specific apps corpse. It should be a white file delete it.

If that is unsuccessful then there is an app called SdMaid (no affiliation) that has a corpse cleaner that should do the trick.

If that does not work then try Google's suggestion of one of the following:

METHOD 1:

Go to Setting >> Go to Application Setting (In some devices application setting is named as apps). Go to, All the apps > >Find the Google Play Store >> Clear Data and Cache Once you have clear everything, Next you need to Force Stop the application. Similarly, Find the Google Play Service >> Clear Data and Cache Also, Find Google Services Framework >> Open Google Services Framework >> Clear cache and data Now, Restart your device and try to download the app. It has worked for many users and hopefully it will work for you also. If it didn’t worked for you, go to next method.

METHOD 2:

Go to Setting >> Storage >> Scroll down and select “Unmount SD card” Open Google Play Store >> Download the app again that was giving you the error message After successful installation, Go back to Settings >> Storage  >> tap on “mount SD card” If above steps didn’t work, also try removing your SD card before installing.

METHOD 3:

Go to Setting >> Accounts >> Google Remove all your Google accounts Go back to Google play store and Sign–in your account information Accept all the Google terms and setup Google settings then Run Google Play Store and download the app. Removing and adding the Google Account has solved the issue for many users as there was problem with the Google account. If this help you to fix the error then the job is done otherwise head to next method.

METHOD 4:

Most of the users have found this solution to be working fine. After changing the storage setting users were able to download the app without any error message displaying on-screen. Steps to change the Storage Setting:

Go to Setting >> Storage >> Preferred install location Tap on Preferred install location, a box will pop-up with different option Select “Let the system decide” option Open Google Play Store >> Download the app again that was giving you the error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.