0

I have a Leagoo T10 phone running Android 6.0. I am unable to connect to a USB thumb drive using a USB type C OTG adapter. I am also unable to connect to my Canon SLR camera using the DSLR Connect app (the camera and app works using another phone using a later version of Android).

There is no option on this phone under Settings -> Storage to connect to a USB device that I can see.

I've tried turning on USB debugging, and changing the USB configuration to MTP. No joy.

The OTG device is working - I'm able to connect the phone to my DJI Osmo Pocket with it. The USB thumb drive is also working.

When I open op OTG Disk Explorer, I get the message "Cannot mount the USB Drive. No device found".

The specs of this phone state that OTG is supported.

I've tried everything that I know to get this working. Does anyone have any suggestions?

  • What format is the thumb drive? I have had the best luck with OTG using a file explorer like solid explorer (plug-in), FX explorer, or whatever other ones there are. – Bo Lawson Jan 24 at 13:37
  • No luck. USB does not show up in either of these apps. File format is FAT32. I think that there should be an option on my phone to connect to USB storage, but I can't find it. I managed to work it out on my other phone (Sony Z5 Compact). I've just ruin the USB OTG Checker app - and it says that my device is USB OTG compatible. – Robert S Jan 25 at 7:34
  • Since the DJI Osmo Pocket works with the devices OTG. The first probable cause that I can think of is the devices host power output might not be enough to power the thumb drive or camera. It is supposed be have an output of 5v but not all OEM follow protocol. The next thing I would check is the presence of /system/etc/permissions android.hardware.usb.host to make sure it has the permission android.hardware.usb.host and handheld_core_hardware.xml has the feature android.hardware.usb.host. however, without root you can only verify if its not present you will not be able to edit or add. – Bo Lawson Jan 26 at 8:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.