This is one of the some thousand limited edition Google IO handout Samsung Galaxy Tab 10.1 devices. Was known working for quite some time, and susceptible to the "sleep of death" that left it not powering on until you long press the power button while touching the screen.

Device has never been rooted, used only lightly, never dropped, everything points to a simple software/firmware problem (doesn't even have the screen glue problem like others in its batch). Charging cable works (and has worked in the past), device "should" be charged (left plugged in overnight), though they designed it without any hardware indicators of charge status.

Things I've tried that numerous forums like XDA and android Forums recommended (but do nothing):

  • Hold power button for 30 seconds
  • Hold power button for 30 seconds and touch/wiggle finger on screen (used to help, no longer does anything)
  • Hold power and up/down volume alternatively (or any combination thereof)

At this point, this is theoretically just an expensive paperweight, therefore I am quite willing to do damage to it to get it working again, or simply use it as parts. This must be a "simple" firmware problem, so I feel that I shouldn't have to take a spadger to it and wrench out the battery or solder in a debug cable just to get it to do something.

Any ideas?

EDIT: To note, on neither Windows or Linux does any device show up or get mounted when the device is plugged in during any of the procedures mentioned above. Nvflash sees nothing.

EDIT 2: To those reading unfamiliar with the Galaxy Tab 10.1, it seems to be a mostly poorly designed device with only three physical buttons (Power, Volume Up/Down), and possibly zero indicator lights. This makes the number of options left for the consumer to debug it next to nil. I'll wait a week, and unless anyone has a better idea, I'm literally cracking the sucker open and physically removing the battery.

EDIT 3: Okay Android peeps, I couldn't wait any longer and went ahead and cracked the sucker open. They were right, the back plastic is very delicate (and snapped in two places, purely cosmetic though). It's fairly tidy inside, and the battery and guts are easily exposed. My attempt to read the voltage of the battery revealed it to be.. basically dead. No real voltage at all. My best guess at this point is that somehow the charging circuitry requires some kind of minimum current available in the battery before it will attempt to charge it (or perhaps enough to boot and allow the software to handle it). Seems pretty stupid to me. If I can get my hands on a replacement battery, or a something to charge the existing battery directly, OR a wall wart to provide the 3.7 volts directly, I will try that.

Other than that, looks like I'm totally SOL and I'd have better luck posting into the Hack-a-day QA forums than a respectable software specific support forums like Android Enthusiasts. Thanks again guys! Maybe I'll be back again later for assistance getting Ubuntu installed on my Droid 1.

FINAL EDIT!: After a quick jaunt over to Hackaday, I got some confirmation that the actual read voltage across my battery terminals was BELOW the minimum for Li-Ion, so they battery was basically dead. Another quick run to ebay found me a "new" one for ~$35. 5 days later and I shoehorned the new battery in and tada! It works! .. sort of.

Due to the undue stress of being discharged (or perhaps being so lonely), the boot process was broken and it was stuck in an endless boot loop. AFter about 4 hours messing with it trying this method to do fastboot and user wipe, but finding out that windows failed to recognize the it as anything but "Unkown Device", after another 2 hours of hacking around i come to find out it's my horrible cheap chinese knockoff cable that's the culprit!!

Found the original cable, plugged it in, fastboot works, try to wipe with fastboot -w, just hangs. Fooey. Next I follow this unbrick method using the odin download to flash a "Stock" rom. This works! Yay!!! Unfortunately it's back to android 3.2... but I can't complain, as I am now the proud owner of a $35 (+ 10 hours of work) android tablet.

What an adventure. Hopefully this log will help someone else along the way in their own tablet adventure.


6 Answers 6


Final Answer (to wrap up the question) [short version]: Battery was utterly dead, when popped open and measured at the tabs, voltage was under the safe minimum. New battery ordered from eBay plugged in, tablet worked! Just had to to escape from a boot cycle of doom, root and install Cyanogenmod 9 alpha (of which there are numerous available tutorials for both of these around the web)


I remember reading where someone had a similar problem with his Droid X (software failure, and the bootloader / recovery mode doesn't charge the battery), so he provided the voltage directly long enough to flash / boot normally, then reconnected the charger and battery.

If you can at least get it into the "device is off but charging the battery" mode, you should be fine from there. Sorry I can't be more specific in regards to your specific tablet.

  • This probably would have worked, assuming the battery could actually be charged again (which it can't according to this great walkthrough), though the galaxy tab actually has TWO batteries that work in together, and I'd have to match the voltage exactly, and all this while risking killing the device. Only for the brave of heart and equipped with a really good bench power supply would I recommend it. It's probably be easier to charge the battery itself at that point (though I don't recommend that either.. fire danger!)
    – TechNinja
    Apr 11, 2012 at 17:31

My wife and I each have a Samsung Galaxy Nexus phone and I've seen this exact issue from both of our phones. The devices can get into this bizarre state where they have a dead battery, yet won't charge when plugged into a charger. On our phones the solution is to remove the battery, wait a few minutes, then insert the battery and apply power from a charger. From there we get the battery charging icon without the device powering up. Have you tried disconnecting the batter from the rest of the tablet? There is an image here showing which connector to pull:

Disconnect battery on Samsung Galaxy Tab 10.1

Also, some devices can power up with the battery disconnected and only connected to wall power. I'm not sure if the Galaxy Tab 10.1 behaves in this way, but since you've already cracked the case it is worth a shot.

  • Nope, no help there. The design is such that the battery is 100% required. I know I would never design such a device to be so dependent on what amounts to basically a car tire that will eventually wear out or go flat, not to mention to lock it behind a non-user serviceable area. Sheesh! if you can't open it, you don't own it.
    – TechNinja
    Apr 11, 2012 at 17:28


I faced a similar problem of a seemingly hard-bricked Samsung Galaxy Tab (not sure which model; a rather modern one).

When reading xda-developers on this matter, among many discussions of this topic, I stumbled upon an article which was slightly off-topic, but still interesting for me to look through it: it dealt with modifying the hardware at home (jumpers, soldering), so that it becomes like a "developer board" (used at Samsung), with more special modes of operation (here: unbrickable mod).

And it said under "Special instructions":

A potential solution:

The normal battery charging sequence [after the modification] can be activated by holding power for 4 seconds, then plugging in the device

I had the crazy idea to try this on the dead device, although this wasn't advertised as a method to unbrick the normal, unmodified Galaxy Tab hardware.

(No other method had worked, like charging for many hours, or pressing various button combinations.)

My story:

So I pressed the power button, held it for at least 4 secs, and then without releasing it, plugged the charger into the tab.

And it powered on!

(It was 100% charged.)

I thought about this in the following way: some error occured in the powering-on-and-charging circuit, and the described trick reset it, and forced a normal mode in it.


Perhaps, what did the trick was the other method mentioned here: to hold the power button, and touch the screen. I'm not sure.


I thought I would have to snap off the cover to do the battery thing, but then I found the original cable charger and within minutes after holding down power button and volume button up it booted up . It is now charging nicely. I had been charging my tablet with a cheaper dollar store charger previously. Try this before attempting to mess with the battery.


I've had this problem many times and also tried everything others post. Heres what works for me: Plug your charger into a desktop I guess it reboots it I really don't know, all I know is it works. I actually had to do it today, so I though I would post my fix. Good luck

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .