0

I have a Samsung Galaxy Tab 4 T235Y LTE 7.0". I have ported and flashed rom and it went wrong. Then I flashed stock rom. Now it's not detecting usb on pc (not showing usb options in tablet like mtp/ptp selection) and only charging device. Also when I turned off the device and put into charge offline charging animation isn't showing. Twrp recovery usb also not working. Usb works only when in odin download mode. Please help me to fix this !!

  • defective USB cable/connector? Or you're missing Samsung USB drivers (MTP drivers).? If on Windows, check what is shown in Device Manager – esQmo_ Jan 27 at 17:19
  • Usb cable is branded one and it's working with other devices. I have checked my tablet pc with several cables also. No damage with the usb connector port. – Reshan Kariyawasam Mar 10 at 8:22
  • There may be init.usb.rc / any file intergrated with usb connection missing / damaged – Reshan Kariyawasam Mar 10 at 8:23
  • hum... not sure about init.usb.rc... but try this: Open the dealer, dial *#0808# then select MTP/ADB, reboot. If not working, you should try flashing ''rapair" firmware, the one with 4 files – esQmo_ Mar 10 at 13:32
  • I tried all long ago! nothing worked – Reshan Kariyawasam Mar 17 at 17:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.