3

My Galaxy Tab 10.1, 16GB Wifi only version, disconnects the WiFi whenever the tablet goes into sleep mode.

I have ensured that I have selected to never sleep in advanced WiFi settings.

I downloaded and experimented with the Wifi Keep Alive and REGPON wifi KeepAlive apps, but they have had no effect.

I even tried rooting the device, and put on this ROM, in hopes that maybe some change would take effect, but it hasn't.

Is this a known issue with the Galaxy Tab 10.1? I've done some Google searching and I've seen other people report it, but most fixes seem to just describe how to go into the advanced settings and enable "never" as an option.

Is there any kind of fix I can apply?

This is a somewhat critical feature for me, as I intend to be able to receive Skype calls, which can't be done if the WiFi disconnects.

  • Does this happen when it's been asleep for a specific period of time (i.e just a few seconds or several hours)? Also, does this happen on every WiFi AP you connect to? – Mr. Buster Mar 20 '12 at 23:01
5
+100

In a nutshell: using a static IP is like owning a house. Having a DHCP lease is like renting, but you may have to move when the lease is up. Unfortunately, the Tab's implementation is like a renter who leaves, then tries to get back into his old apartment (which in this analogy is a dynamically assigned IP address on your WiFi network) and finds it locked. Instead of asking for a new lease, it just keeps knocking on the door, never to enter. In this case, it means that your Tab won't connect to your WiFi network on wake.

The detailed explanation: It looks like Samsung's implementation of DHCP lease renewal is at fault here. When a device wakes up and then tries to connect to WiFi, it will ask for a DHCP lease (if expired), which also gives it a dynamically assigned IP address. This works fine when the Tab first connects. However it looks like it never asks for a new lease and thus new IP address. Instead it caches the IP address and keeps trying to reuse it. DHCP is dynamic so it means that any particular device on the network cannot rely on a specific IP. So eventually the lease will expire and/or the IP address that the Tab is using gets reassigned to another device. When this happens, your Tab cannot connect to WiFi.

So the solution is to assign static IP until the Tab's implementation of DHCP lease renewal is fixed.

An alternative solution is to root your device. Then you can manually delete the cached file which contains the stale IP address following the instructions at: http://steve-shaffer.com/2011/02/samsung-galaxy-tab-wifi/ (where I learned about some of these details as well). This will cause the Tab to renew the DHCP lease properly and live in a brand new and shiny dynamically assigned apartment on your WiFi network.

2

Changing the network connection from DHCP to a static IP address has resulted in connection stability.

(I can't reclaim my own bounty, and it would be a shame for all that rep to simply disappear, so, someone can still claim it by providing an answer that is informative and helpful in some other regard. Ideally a solution that doesn't require using static IP, but also maybe information on why DHCP is unreliable, or even just alternate workarounds that are equally effective. Or something else entirely.)

0

Not sure what the problem really is, but this worked for me:

  1. Use static IP for the TAB from your router
  2. Remove all files in TAB under folder /data/misc/dhcp. This step requires root access, then the files can be removed with ES File Explorer
0

I have tried everything on many forums to address this wifi connection problem. My daughter finally said to me "maybe it's the browser". I downloaded Firefox, and voila! no more problems. I am very very low tech and barely know what most of these terms mean (IP,DHCP,access point?). But I DO know how to download an app and that's what did the trick. Simple. Apparently the browser that comes with the tablet sucks.

  • not sure how installing another browser on a device solves wifi connection issue! this post is more suitable as a comment below the question, IMHO – AADAndroidEnthusiasts May 17 '16 at 5:05
0

Something else that owners of these models may experience, worth adding here.

Quick specs on my issue: Android 4.4.2, KitKat, July 2014 kernel, T5200XXUANG1 build (Australian); I put that in this post in case it ever helps anyone visiting the forums. Again, this is a Samsung Galaxy TabPro 10.1, model SM-T520.

My unit would only barely pick up my home router & Galaxy S5 phone wifi hotspot. It was also not picking up any nearby neighborhood wireless router & there are a ton of them. Since I hadn't removed the back yet & thought perhaps unplugging battery from motherboard may help, opened back & EUREKA! The actual physical wifi card cable was UNPLUGGED! Unclear how that would have happened but now I know why it was in such good shape & the eBay seller was letting it go so cheap.

So, certainly remove the back cover & physically inspect the unit. Amazingly, it's not always the OS, software, or router settings to blame.

-1

I'm having this issue with a captivate running CM9. It only happens on certain networks. I can't attribute it to DHCP/Static since thats IP and it runs higher in the stack than the physical connection. Only guess is with static IP the device isn't entering low power state on the wifi chip, where with DHCP it may allow that.

I've got some access points that show me connected clients, active, inactive, or inactive standby. Certain access points/routers may disconnect clients that don't respond frequently enough (in standby state).

My ubiquiti unifi access points don't disconnect my phone when in standby, my ubiquiti pico2 access points do. Linksys WRT54G does disco in standby, while my Motorola eXtreme Docsis 3.0/Wireless Router at home does not. It is consistent in each location, so I attribute it more to the access point actively dropping a standby connection versus it being something wrong with the phone.

-1

I as well have the stealth trio 10.1 and i as well kept getting dropped off my wifi so i connected my trio to my computer and kept usb off then i had to go in to my router settings go to wifi protected set up and then i had to go to my trio go to settings and then go to wifi and then there is three little grey dots on the top right corner put your finger on the tree squares you see and slide your finger down you will see three options scan,.............. wps pin entry,............... advanced, you want to press on ..........wps pin entry.......... and you will see an 8 digit pin after obtaining that pin go to your wifi security on your router page and put those numbers in the empty box and then press enroll and just below that you will see a button that says start pbc press on the pbc button and your trio should now say connecting to wifi and it will tell you if you succeeded in connecting your device........... .this is also known as pushing the wifi. let me be clear on one thing my router is a Belkin router so if you router is a different type of router you setting my be different so dont forget to call tech support for your router if you are having trouble with this set up its worth the effort.

  • 1
    That's a wall of text, and hardly readable (I gave up at line 3). Mind to edit your answer and apply some formatting, so it becomes readable? Thanks! – Izzy Jan 12 '14 at 8:42
-2

In Settings - WiFi - Advanced - Turn off "Always allow scanning" option.

It worked for me, WiFi is now stable.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.