0

I have Huawei Mate 9 with Huawei health app preloaded. I travel most of the time by trains. I noticed the Huawei health recogizes any shaking in the train as steps while I am just standing or sitting. That's why I quickly reach 10,000 steps which are not real steps and the burned calories are not real in return. How do I stop my phone from identifying shaking in public transport as real steps while I am standing still. Do I have something wrong with my device?

2

I'm not sure what all sensor data is being used by the app, but most would rely on the input of the accelerometer. And as such it is all based on its algorithm as to what kind of moments it identifies as steps. While it is hard, the sensor on the device can be giving out wrong values. But I'd still suspect that the companion app is not able to differentiate between steps and the shaking of hands due to you being on the train. It's quite tricky for it too. I'd probably just turn off the app while in the train. We can't expect a very good amount of accuracy from an app which isn't reading anything from the body. They can probably improve it by using GPS data and other sensor data to understand if the person was actually moving at the natural pace.

1

(I know this is an old thread but this is still a big issue with a lot of phones models and ppl might still find this universal solution useful)

Rootmode method

I disabled Samsung Step Counter sensor and Step Counter Detector sensor in android 10 by doing the following:

  1. Uninstall Huawei Health application.
  2. Activate Developer Options: go to Settings > System > About phone>Tap Software info > Build number>Tap Build number 7 times
  3. Enable the Sensor Toggle: to do this go to developer options find and tap "Quick settings developer tiles." enable/toggle "Sensors Off" button, it will turn off your compass, proximity sensor, accelerometer, gyroscope, and any other sensors. Note: on this step in Lineage OS 17.1 the Sensors off option only added this button/icon in android status bar (near wifi button/bluetooth button/etc) so you still have to tap on it to deactivate sensors.
  4. Once all sensors are off you need to edit your build.prop file (either install a tool like BuildProp Editor- you need root mode, or use file explorer with a built-in text editor). The 2 lines that I've added in my build.prop file are: Code: ro.qc.sdk.sensors.stepdetector=false ro.qc.sdk.sensors.stepcounter=false 5.Restart phone. Install Huawei Health
  5. Enable back sensors by taping the Sensors Off button in your android status bar. Additionally you can repeat step 3 to remove the sensors button from your status bar.
  6. Open Health and check if the small ! exclamation sign from main window is gone or at least if it doesn't display your steps counter from phone.

PS I had to do this on one of my phones because Huawei app was restarting the phone randomly. It took me a while to find the culprit and apply this solution. Since then I tested this method on various other phones I own and it worked on all.

For non rooted phones use adb method ("adb pull /system/build.prop") to edit and upload the build.prop file. For more details on how to use adb pull and push commands google search, there are some nice tutorials out there and I don't want to copy/paste someone else's work.

Trying to to this without respecting the steps will result in failure.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.