TWRP 3.2.3 asks for a decrypt password at startup, which I never set. Ignoring with 'cancel' leads to the main menu, but then the internal storage is marked as 0 byte (e.g. when trying to backup), which is not the case.

I understand this is related to default encryption of the data partition (correct?) by Android (my phone has Android One).

Is there a default password?

The PIN/password used to login into the regular OS do NOT work. I've seen many answers saying so (e.g. here or here ), it is not true (at least for my version of Android). I tried with numerical PIN, password, or nothing (each time going back to factory reset), and nothing worked in TWRP.

I know there are other related questions, but none of the answer provides details or seem confident enough:

here here here

This answer refers to a misterious "disable force encryption" package, which I've also read about in other posts.

Is it really the way to go? What exactly is that package? And what does it do?

Can I not completely disable encryption in Android OS?


I want to mention that I manged to circumvent the problem temporarily, by recreating the data filesystem within TWRP. This of course wipes out your data, but at least afterwards TWRP sees your internal storage and one can do a backup of the system. However, upon reboot the phone gets stuck in the initial loading (white screen with color bar in Android one), so I have to reboot again to the stock recovery and do a reset. Which brings back encryption, and I am back to square 1.

2 Answers 2


It's a issue with TWRP and the ROM you are using. TWRP is able to decrypt till Android 8.0 but if you're using a ROM above it you'll get this error and after flashing your data partition to ext4 it will let you use that space till ROM boot up and encrypt again. There isn't a solution yet. TWRP releases updated version 3.2.3_1 for few devices only which has this bug fixes.


Android devices with full-disk encryption (FDE), such as yours (usually Android 7–9), may support the forceencrypt fstab flag, which causes the device to encrypt (again) on (first) boot.

Thus, while you can “Format data” in the “Wipe” section in TWRP to have an empty but decrypted “/data”, the OS will encrypt again on next boot.

You must therefore prevent encryption of “/data” from occurring for your use case to work.

Try looking at “Universal DM-Verity, ForceEncrypt, Disk Quota Disabler” [1] or otherwise Magisk [2] [3].

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .