3

Long story short, microG is supposed to take advantage of signature spoofing in order to do his magic. But I couldn't make this happen.


Context :

I just did a clean install of Havoc OS (Android Pie) on my Oneplus 3 using this thread.

This distro is supposed to natively support Signature Spoofing, as it claims in its features list (twice). And migroG is officially supported. But there's no support provided on SourceForge (official website for Havoc OS) and the way to contact the dev is Telegram (which I don't use).


What I've tried ?

There is a switch available in the Settings app, and according to the terminal, it's working : settings get global allow_signature_fake returns 1 or 0, depending on that switch.

However, when trying to check with microG or with this checker I get a negative answer.
You can see it on these screenshots :
enter image description here enter image description here

Over the 600 pages of the official thread, I saw other people having issue with this but noone really have a working solution.

Some said they used a Magisk module called NanoDroid, but in its today's version, this one detects that the distro already allow it and do nothing. Plus, I read this override on distro natively supporting it is not recommended anyway.

According to this thread :

LineageOS for microG since December updates refuses sigspoof to work when the permission is not defined in privapp-permissions, this is now the case (on all ROMs with native sigspoof support)

As Havoc OS is based on LineageOS, I've tried that too.
I've then installed a magisk module called [Terminal] App Systemizer and use it to swap both apps (Checker and microG) to /system/priv-app.

Then after reboot I've got some progress : Signature Spoofing Checker still says "Disabled", but microG show one more checkbox filled (System grants signature spoofing permission). See the screenshot :
enter image description here

Now I'm stuck and have no clue were to go next. Any idea ?

  • Have you tried Xposed method, if you already running xposed, (not sure about compatibility with Pie), but on my device Android 4.3 runs perfectly with signature spoof – xavier_fakerat Feb 5 at 19:35
  • @xavier_fakerat : this is android pie, not supported by Xposed framework. it's not even stable on oreo... – Stopi Feb 8 at 4:26
  • oops my bad. You are right – xavier_fakerat Feb 8 at 19:30
2

Havoc Os v2.2 is out, (see on xda thread for Oneplus 3/3T)

This version correct the problem and everything works as expected now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.