0

so i Had a trouble booting into download mode on my Samsung Galaxy J4 to boot twrprecovery.img and not flashing it after enabling "developers options" and "USB debugging" and "Unlock OEM" now bootloader is already unlocked under "Unlock OEM" I tried adb devices it saw my phone I did adb reboot bootloader it did not boot into bootloader so after a little research I found I had to use adb reboot download I could enter download mode but when doing fastboot devices with normal, sudo and su privileges it simply doesn't see it while in OS mode nor in the download mode. I tried booting into bootloader via recovery mode using poweroff+Vol up+Homescreen and then navigating to reboot to bootloader it simply reboots to the OS. so why adb sees devices but not fastboot?

anonsam-X550CC ~ # uname -r
4.4.0-127-generic
anonsam-X550CC ~ # cat /etc/os-release 
NAME="Linux Mint"
VERSION="18.3 (Sylvia)"
ID=linuxmint
ID_LIKE=ubuntu
PRETTY_NAME="Linux Mint 18.3"
VERSION_ID="18.3"
HOME_URL="http://www.linuxmint.com/"
SUPPORT_URL="http://forums.linuxmint.com/"
BUG_REPORT_URL="http://bugs.launchpad.net/linuxmint/"
VERSION_CODENAME=sylvia
UBUNTU_CODENAME=xenial

Phone Model : SM-J400F/DS
Baseband version : J400FXXU2ARI2
Build number : R16NW.J400FXXU2ARK2
Android version : 8.0.0
Android security patch level : November 1, 2018
  • 4
    Samsung devices do not have "fastboot" but use a proprietary system. You must use Odin/Heimdall to communicate with the device. You cannot communicate with a Samsung device with fastboot. – acejavelin Feb 8 at 15:13
  • I'm not trying to flash i'm just trying to boot twrprecovery.img, I think odin/Jodin/Heimedall only flashes a rom – SanoneSam Feb 8 at 16:22
  • Still, Samsung devices do not support fastboot in any way, you can't just "boot" TWRP on them, you must flash it. – acejavelin Feb 8 at 20:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.