I have this problem on my Marshmallow device. My issue is with select apps on my device, particularly the Expedia app. I can get some native apps to work, including Shazam and Google apps (Youtube, Maps, Chrome, etc). This only works from Firefox, by long-pressing the link and choosing Open with [app name].

I have enabled the app settings to "Open in this app" under Settings -> Apps -> Configure Apps (gear icon in top right) -> App links -> Expedia -> Open supported links. Expedia links, including www.expedia.com, are in the supported links list.

For Android system settings I do not have a section called "Default" under App Permissions. However, under Settings->Apps->Configure Apps (gear in upper right)->Default Apps I have 4 options "Assist & voice input", "Browser app", "Phone app", "SMS app". There are no other options. No default browser is set, but the phone and SMS apps are set.

Despite this, I do not even see the option of opening with Expedia when Using "Open Link With" and "Best Open With" apps do not work. For example, when using the Open Link With app, I only have Firefox and Chrome offered as apps to share with. When I disable Browsers as opening options (a feature in Open Link With) and I try to share with the app, I receive the message "No other application found to handle the URL" from Open Link With (see https://github.com/tasomaniac/OpenLinkWith/blob/master/app/src/main/res/values/strings.xml).

I tried rebooting my device. I tried reinstalling Expedia. I cannot update my stock ROM beyond Marshmallow. I am very hesitant to Reset App Preferences because I'd have to go through them one by one to reassign permissions as appropriate. For me, Chrome is more restricted than Firefox, e.g., I cannot open Youtube links with the native Youtube app through Chrome, but can with Firefox by long-pressing the link and selecting "Open With YouTube App", as similarly noted above. I also have the same problem using Chrome on a Samsung tablet with the Expedia app installed.

Can anyone verify they also have this issue on Android Marshmallow?

I understand that some apps may have their "intent filter" programmed incorrectly (from Force link to open in app not my default browser). Can anyone verify if Expedia has this programmed incorrectly, or if is it a Marshmallow issue? If there's a solution, any suggestions (aside from reverse engineering, reprogramming and rebuilding)?


You must log in to answer this question.

Browse other questions tagged .