0

I'm having some problems with my Samsung A3 2016 (A310F), on Android 7.0.

I rooted the device using Odin3 v3.12.3 and flashed TWRP 3.0.2.1 SMA310, and then installed SuperSU v2.76 using the TWRP that had been installed.

Unfortunately, whilst the phone had become rooted, there were a number of problems with the device. The Wifi button became stuck and greyed out in the "off" position, the camera wouldn't work, SD Card storage is not showing, and when connecting the phone to my PC via USB it doesn't open Explorer like it did before rooting (I can see it in Device Manager, but it is impossible to access the phone). Furthermore, the phone cannot access the Internet using mobile data either.

I have tried to clear the Cache and Dalvik Cache via TWRP, and reset network settings, neither of which has worked.

My research has suggested that perhaps SuperSU v2.76 is the problem, and that I would need to use SuperSU v2.82. However, I cannot find any way to get SuperSU v2.82 onto the device.

I suspect I need to start from scratch somehow, but I'm very new to Androids and rooting and I'm not sure what to do.

Can anyone please give me some advice?

  • If you can still access TWRP, try flashing 2.8.2 from the links here – Dan Brown Feb 14 at 10:55
  • 1
    I can still get access the TWRP menu, however how do I get 2.82 onto my device? My PC no longer picks up my phone when connected via USB (it did prior to rooting), and the phone won't connect to the internet via mobile data, nor does the phone recognise the SD Card. – AdrianShepherd Feb 14 at 13:48
  • Have you tried mounting the SD inside TWRP itself? – Dan Brown Feb 20 at 11:43
0

In case anyone else has the same issue, I managed to solve the problem.

I unrooted the phone using the option in SuperSU, and then flashed the device with the stock firmware using Odin.

This fixed all the problems, and allowed me to successfully connect the phone to the PC via USB.

It turns out SuperSU was problematic, and that Magisk is a better solution for this particular firmware.

So I placed the latest Magisk build on the phone via USB, then used Odin to put TWRP back on the device. Then, from the TWRP Recovery menu, I installed Magisk.

After this, I installed Magisk Manager from GitHub.

The phone was successfully rooted after this point, and all functions are working properly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.