I have a Pixel 3 XL with Android P, and for the last 3 days, my phone started vibrating almost every hour, at exactly hh:10m, but without showing any notifications.

After much time, I found some sites indicating how to find the origin of the notification: adding a Settings widget to my Home screen, with a Notification log (otherwise I couldn't find the entire log anywhere else). This revealed the cause is Download Manager, informing me at 3:10 AM that I downloaded a file 3 days ago.

Now, I don't remember if I tried uninstalling it from the phone, but the fact is that there is no such app in the Settings -> Apps & notifications menu, so I cannot change its notification settings.

I tried going to the Files app (as some sites mentioned), which states "Notifications: on", but when I select it, the Categories part is empty, so there is nothing to disable.

So, which app is actually emitting the Download Manager notifications, and how can I disable them?


When searching for Download Manager under Settings -> Apps & Notifications you missed listing out the system apps. List them by tapping on the three dots line in the upper right corner and choosing show system apps. Download Manager is a system app and you would find it apps list.

To disable the notifications from that app, tap on that app in the list, then Notifications, and choose an option there that fits your needs.

  • Are silent notifications possible for the Download Manager? I want to know the status without broadcasting it to the room.
    – rickhg12hs
    Sep 1 '19 at 18:22
  • @rickhg12hs if you are using Android 8 or above you can change the priority of the notifications. Changing to lowest would still show up in the notification tray but would not disturb you. See i.stack.imgur.com/2glJt.jpg
    – Firelord
    Sep 1 '19 at 18:55
  • That's how I did it on Android 8, but I can't seem to find it on Android 9. I've recently upgraded. Where can I find this control?
    – rickhg12hs
    Sep 2 '19 at 22:27
  • 1
    I haven't upgraded to Pie yet, so try this perhaps: androidcentral.com/how-control-notifications-android-pie. If that doesn't work too, than I suggest you ask a new question.
    – Firelord
    Sep 3 '19 at 3:03

Just wanted to add an answer for this that I found on Reddit, in case it disappears.

This issue seemed to be fixed for a few people by doing the following: Go to settings -> Apps and Notifications -> see all apps -> three dot menu -> show system. Scroll to Download Manager. Clear cache, clear storage, force stop, disable, enable.

Of course, your download history will be cleared if you do this, but it's up to you to decide if that's worth it :)


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.