0

This question already has an answer here:

I have a rooted device Samsung SM-T590 (Galaxy Tab A, 2018, 10.5, Android 8.1.0)

I have Root Explorer app installed

When I try to move some app from "/data/app" to "/system/priv-app" (using Root Explorer) the device reboots and nothing is being saved at "/system/priv-app"

I want to make my app a system one

This method works ok on many other devices

But something wrong with this device

Any ideas how to solve this problem?

I think system apps Device Security and Device Maintenance prevent me to do it.

I tried to delete them using Titanium Backup but phone reboots and they are installed again

Also there is Samsung Knox security technology

It's not a duplicate because this question is about Magisk and not SuperSu

marked as duplicate by acejavelin, Firelord Feb 20 at 21:29

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • This is because of systemless root, which is needed on all versions of Android from Nougat and higher (and some Marshmallow builds). It does not allow you to move apps to the /system folders. I will mark as a duplicate with a link to a question with an answer for the method to do that, as you must do it with TWRP, hope it helps. Note one of the options is to convert to traditional root, I don't think that is possible with Android 8.1 – acejavelin Feb 20 at 14:45
  • 1
    @user924 have you tried the answer that acejavelin suggested? If it's not a duplicate, then please edit to make it clear why the question is not a duplicate, or why any of the answers don't work for you. – Andrew T. Feb 20 at 15:46
  • @acejavelin before we continue I have to say that I use Magisk when that question talks about SuperSU android.stackexchange.com/a/171298/243385 – user924 Feb 21 at 6:53
  • @acejavelin there is no difference if you do it with TWRP or Root Explorer. Both leads to reboot, they both just try to move apk to system folder – user924 Feb 21 at 7:12
  • @acejavelin Magisk works fine on Xiaomi Mi A1 8.1 and I can do there anything I want – user924 Feb 21 at 7:19