0

I recently installed again whatsapp in my new smartphone android but the local backup doesn't work automatically. Today I pressed back up for the google drive backup and it also included the local backup. But for the past weeks whatsapp never did the local backup automatically. Do you know why?

0

Most likely your phone is a bit aggressive about killing the background tasks. So, WhatsApp is unable to wake up the phone at its usual 1-2AM slot to perform a backup. A lot of phones are doing this to ensure a better battery backup and standby.

Do note that notifications may still flow even when WhatsApp is not allowed to do tasks related to backup in the background. But most of the times, they are either delayed or only show up when you first turn on the phone display in the morning.

  • Thanks. In case you are right is there something that I might do for this issue? – Mark88 Feb 21 at 21:42
  • Depends on which phone do you have. Most phones do allow you to reduce how aggressivly the phone kills the apps. Check in Settings > battery if you have a setting related to background activity. Another (usually different from each other) should be in: Settings > Apps > WhatsApp > Battery > Don't optimize. – singhnsk Feb 21 at 21:43
  • Thanks. In my new smartphone under 'battery' it says 'power saving exclusions' but I think it is the same thing. – Mark88 Feb 22 at 7:59
  • I tried to exclude power saving features but it didn't to the local backup automatically. Any other possible reason? – Mark88 Feb 23 at 7:48
  • Not sure. WhatsApp not running in the background is the only practical reason for it to not backup automatically. I don't have any other suggestions. – singhnsk Feb 23 at 14:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.