5

I tried to flash ClockworkMod with Heimdall on my Galaxy Mini by doing the following:

  • I go into download mode
  • Plug in my phone
  • Go into the recovery image folder
  • Run heimdall flash --kernel zImage

I get this error and my phone stays in download mode:

Initialising connection...
Detecting device...
Claiming interface...
Attempt failed. Detaching driver...
Claiming interface again...
Setting up interface...
ERROR: Setting up interface failed!
Re-attaching kernel driver...

USB debugging mode is enabled of course and I'm on Ubuntu. How can I successfully flash ClockworkMod?

5
  • Try connecting your phone to the PC via USB after starting the Heimdal tool.
    – Chahk
    Mar 20, 2012 at 12:33
  • i tried it but it fails detecting the device btw is heimdall compatible with galaxy mini right ??
    – kosaidpo
    Mar 20, 2012 at 13:32
  • 1
    Sometimes this is a permissions issue. If the command works with sudo in front of it but not with your user account, you don't have the proper permissions to the device. I'm not sure Heimdall uses ADB permissions - the Heimdall webpage should have more details.
    – Broam
    Mar 20, 2012 at 13:33
  • 1
    i have run it again with sudo but i get the same error as before
    – kosaidpo
    Mar 20, 2012 at 13:50
  • Does the computer recognize the phone at all? What does adb devices terminal command return? (you may need to install Android SDK if you haven't already)
    – Chahk
    Mar 20, 2012 at 19:42

1 Answer 1

6

I just a got an email from the Heimdall dev, he said it's not compatible with the Galaxy Mini. Thanks guys for your replies.

2
  • Too bad, thanks for letting us know the answer though. Mar 21, 2012 at 2:28
  • @roxan i can't now tomorow ill :D
    – kosaidpo
    Mar 21, 2012 at 12:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .