1

Beforehand: Sorry for asking. I was sure this wasn't duplicate.

I have made myself a soft brick. The story: used kingoroot or something similar, then was too much in a rush hitting the "yes, please, ruin my rooted device via a firmware update!" button.

Now I made it to this exact situation:

  • I can reach recovery mode
  • I get the right answer when testing for root in recmode
  • I think I got the right rom file but it wont install correctly neither from adb sideload nor via applying it from external sdcard

My guessed salvation: updating the bootloader because I think this gives me the problems with sideloading. I'm here to ask if this is correct and if so how one does so.

EDIT:

Apparently I made some mistakes. The rom archive lists some roms that are neither tagged by OTA nor by a build number (I think I have to choose one of those because None of the ones that have a build number have the one I need). I need build number B116 because it says so an the recovery screen. I choose this one because I am a native german speaker. Is this the correct file?

I unpacked the file and found a file named update.zip containig something that looked like a system. I tried to sideload it and I tried to apply it from sdcard both didn't work.

EDIT:

Whenever I try to sideload the rom sideload gets stuck at 52%. Trying to install it via sdcard results in abort.

EDIT:

The most successful way seems to be installing from sdcard which I reread how to do here. I forgot to put the package into a directory called dload. When doing this installation does not abort in a split second but rather a few seconds later saying can't install this package (2016 02 27 17:38:09 CST over newer build (Thu May 4 14:58:09 CST 2017) shame is, that the newest non-OTA builds are all older than the given date.

  • ADB and fastboot are different. Former is accessible when in ROM or (custom) recovery, later is accessible only in bootloader mode. There could be more than one bootloader modes on a device, one is fastboot. So, fastboot won't be available in recovery. Flashable zips for recovery and fastboot are different; one can't be flashed in other mode. Now what's your question? – Irfan Latif Feb 26 at 19:52
  • question: why doesn't flashing work and what can be done to make it work – Abraxas Knister Feb 26 at 20:04
  • The file you linked is an OTA file i.e. it's just an update, not the complete OS for your phone. It can be applied only to a working ROM. If you want to flash complete ROM, find the stock ROM flashable file for your device. Or flash factory firmware using flasher software from PC. If you have an unlocked bootloader, you can also go for custom recovery and custom ROM (provided that those are developed for your phone). – Irfan Latif Feb 26 at 20:32
  • ok, didn't know about what OTA means either, thanks again. I'll try to find the right image and flash it via sideload if that works. – Abraxas Knister Feb 26 at 20:50
  • Found all roms. I need Y360-U61V100R001C577B116. Unfortunately for B116 there are no full roms only OTA roms. Can I use one from a different build? I tried but I got * failed to write data 'protocol fault (couldn't read status): Success' * from linux after sideloading. – Abraxas Knister Feb 27 at 7:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.