2

The steps I performed:

  1. Flashed TWRP with Odin
  2. Made backup
  3. Flashed LineageOS 14.1 with TWRP
  4. Flashed SuperSU with TWRP
  5. Flashed Open GApps with TWRP
  6. There was a problem, Google Play Services kept crashing, I decided to restore stock ROM
  7. Restored the backup I made in 2 with TWRP
  8. Opened my restored system and decided to encrypt the device
  9. Either the encryption failed itself or I somehow disturbed it
  10. After restart Encryption Unsuccessful keeps appearing
  11. I restored backup from 2 again I still get Encryption Unsuccessful
  12. I flashed LineageOS again - started nicely
  13. Once again I restored backup from 2 again I still get Encryption Unsuccessful

In the meantime I wiped Cache, Dalvik Cache, Data and System numerous times.

So it looks like the stock ROM keeps seeing the information about the failed encryption process even though I wiped the 4 partitions mentioned above. Interesting part is that LineageOS doesn't care.

Any ideas on how to get the stock ROM back on its feet?

EDIT

Flashing the stock rom with Odin didn't help either

  • What type of backup did you made (how did you do the backup)? – Robert Feb 27 at 18:03
  • @Robert via TWRP "backup" function – Andrzej Gis Feb 27 at 18:05
2

Found out the way to fix it:

  1. Download stock firmware (*.tar.md5)
  2. Flash it with Odin (it removes TWRP and replaces it with a standard recovery)
  3. Start Android - still "Unsuccessful encryption" error
  4. Boot into recovery mode (now it's standard recovery instead of TWRP)
  5. Run factory reset
  6. Start Android - now it finally starts - problem solved
  7. Flash again TWRP with Odin
  8. Restore the old good backup with TWRP
  9. Done

So basically the factory reset form the original recovery mode fixes it.

Also I found out why the tablet bricked. When it performs encryption process it looks like it's off (no lights, sounds or anything). Do not disturb it, after 20-30 minutes it finishes the encryption and turns itself on. Just leave it be until the screen turns on.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.