0

To all SwiftKey users who stumble accross this post: Do not update your SwirftKey app at the moment!

Hello everyone

Today I updated several apps on my Android 9 Huawei Mate 20 Pro (non-rooted), among them also the SwiftKey application. After this update my keyboard was gone, completely. Unfortunately I had the great idea that this could be solved by restarting my phone. But after the restart, when asked for the password (the entering of the pin worked fine; there was a numpad) there was and is no keyboard to enter anyting. i.e. the password.

This issue renders my whole device useless. In addition I have no clue on how to solve this and even if I did, I wouldn't be able to access my phone in any way (I think? Because even a connection to a computer would be denied without allowing USB debugging... Am I right?) - e.g. update SwiftKey again. SwiftKey is the stock keyboard of the Huawei Mate 20 Pro...

I wrote something very similar on the SwiftKey "Support" Page (here) - which is a community-help-itself-site, i think. (It's incredible that there is absolutly no possibility to contact SwiftKey directly, or am I mistaken?) But I thought the kind people here might be (way) more competent, especially if will I have to access my phone through a USB connection without the possibility to enter my password...

Any help is greatly appreciated. :) Many thanks.


Solution:

Use OTG adapter with an external keyboard. For details see accepted answer and this Reddit thread.

0

There must be some other issue that caused your SwiftKey app keyboard to be disabled or uninstalled. I just updated mine (deliberately) to version 7.2.4.22 to test this and the app is working fine. I also restarted the phone and it still works.

Here are some solutions I can think of:

  • If you had an another keyboard installed, such as Google Keyboard (usually comes with most Android devices that ship Google apps), and provided you didn't disable the keyboard under Available Keyboard settings, you should be able to boot into safe mode and use the device. The stock keyboard app would kick-in automatically. Search internet for safe booting in your device.

  • Alternatively, since your device supports OTG host you should be able to use an OTG cable with any standard wired keyboard to enter your password/PIN. For a pattern, use a wired mouse.

  • Thank you for your support and for trying yourself... I tried the first option (it's power and volume down button or volume down button alone [?] after a reboot), but this sends me right back to the password screen... Am I doing this right? The Huawei support recommended wiping the cache (Vol. up, down, Powerbutton after reboot), which didn't work neither. I've thought about your second solution myself and shall try that as soon as I've accuried an OTG cable on monday... Many thanks! – JoeHammer Mar 3 at 2:29
  • While browsing for that cable, it turns out that I don't know nothing about OTG: Can I just buy any USB C (male) to USB A (female) adapter or does it have to specifically support OTG? I.e. does the adapter have to have a OTG card (or similar) in it or is a plain old USB-A-to-C-Adapter sufficient? – JoeHammer Mar 3 at 2:47
  • @JoeHammer I suggest you consider buying one which explicitly supports OTG. I don't know whether both type of cable works, so I'm recommending a safer option here. As for the key combination, I'm sorry, I don't know which one would work. All I know is that if your key combination work and you end up with a screen to enter your pin/password, somewhere it would show "safe mode" on the screen. – Firelord Mar 3 at 4:04
  • Alright I'll consider buying one that supports OTG explicitly or I'll get advice from the store personel... As for the key combination: That's ok, I tried every combination, with three buttons there are only seven combinations. It turns out that (1) all three of them boot the device in a "EMUI"/OS update mode (according to Huawei support, this erases cache also), (2) volume up boots it into "ease mode" where you can do a factory reset (and also a cache partition reset...?!), (3) any other combination seems not do do anything - I never saw "safe mode" anywhere on the screen... – JoeHammer Mar 3 at 9:33
  • Addition: (4) Volume down button on start - the safe mode boot option according to the internet - seems also not to do anything, i.e. I end up at the same password entry screen as before, with no "safe mode" screen anywhere... I therefore don't know how to enter safe mode, or at least, if one of the combinations boots the device into safe mode, the mode is not indicated on the screen... Thank you, though! :) – JoeHammer Mar 3 at 9:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.