1

My 2 year old Z5c (E5823, non rooted, official Sony Nougat update) died while updating some app, and doesn’t show any signs of life since then. Connecting the charger doesn’t turn on LED indicator, but it does consume about 0.90A. I have tried all different reset procedures, and only the first time I tried the 2-minute reset did it vibrate once or twice. Since then it doesn’t ever vibrate either.

If I don’t press the power button before connecting to Linux, then it gets detected as QHSUSB__BULK (Manufacturer: Qualcomm CDMA Technologies MSM) only. However, if I reconnect it , then it gives a USB error related to "USB power limit exceeded” :

device descriptor read/64, error -110

I need to then either disconnect the batter or press the off button next to Sim. My first priority is to recover its data (the phone was encrypted however). And if possible, fix it. I couldn't find its schematics to confirm if it's a hardware issue or bootloader (hard bricked), and would greatly appreciate any tips or advice to further diagnose or fix it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.