Recently I bought a Spice MI 280 with Android 2.3.4, I downloaded apps from the Android Market like App2sd, Task killer, Soundhound etc.

A few days ago Android Market was upgraded to Google Play and when I try to open it it shows a no connection: retry error...although I can browse the net through Opera and uc browser without any difficulty.

When I open YouTube through Opera it shows the main page of the site, but then when I try to play a video it shows cannot play the video.

I have tried adjusting the current date, clearing data and caches etc. I've tried a factory data reset but its asking please input phone password. Any suggestions?

3 Answers 3


Okay, I ran into the same issue and finally found a fix that worked!

First off, go to settings>Applications>Manage Applications>Google Play Store and select "Clear Data" Then, return to your home screen and just wait for the Play Store to auto-update. If it does not come up on its own, re-open the store and select "update" Finally, close the app (after it boots up), give your phone another minute,and have at it!

After trying this, my Play Store has been working just fine. I hope that helps!


  • 1
    The same kind of technique applies to some, not all, apps. :) Go as far as Settings > Applications > Manage Applications, select the app that's giving grief, then Clear Data
    – t0mm13b
    Jun 30, 2012 at 0:07
  • nope doesn't work
    – mchid
    Nov 9, 2015 at 22:15

I'm finding that I can install apps again if I downgrade from Google Play Store to Google Market on an HTC MyTouch running Android 2.2.1.

To downgrade, go to Settings -> Applications -> Manage applications -> Downloaded -> Google Play Store -> Uninstall updates.


I had the same problem with my Xperia ZL. It was supposed to be because of incorrect setting up when the phone booted for the very first time.

I did a factory reset and the issue is fixed for me. So simple.

Good luck.

  • If you have root access, you can also clean up the "host" file content.that sould also work. It is under /etc/ directory. Jul 4, 2014 at 7:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .