0

I have a moto g4 plus(rooted) which is stuck on bootloop. I dropped the device and 1/3 of the screen was gone but the game I was playing was still on the screen. So I restarted my device but it stuck in a bootloop of starting screen which tells you that "your device has been unlocked and can't be trusted". I tried restoring my copy of Stock rom via fastboot but it did not work. The bootloop continues. Out of curiosity I tried getvar command on Fastboot and then I saw that my kernel is still ElementalX and not stock kernel even after flashing the stock rom several times. Can you guys tell me what's wrong?

  • 1
    How did you flash stock? For Moto devices it's a long process. Alternatively, use TWRP flashable version. It looks to be a problem of flashing stock correctly – beeshyams Mar 4 at 11:38
  • @beeshyams I already had stock rom download on my laptop and I used it frequently for any softbricks I suffered in past. And it doesn't work now even if the flashing process goes without any error. – McGucket Mar 4 at 11:50
  • If you are sure that you flashed correctly, lock the bootloader (Moto phones IIRC need web authentication to do this) and check – beeshyams Mar 4 at 11:53
  • @beeshyams yes I tried locking the bootloader even if I don't want to and I don't think you need to web auth to lock the bootloader. I'm pretty sure that I am flashing correctly because I've done it several times. (Thanks for keeping up with me.) – McGucket Mar 4 at 12:02
  • Last shot~ try the TWRP flashable version linked in the first comment. If that doesn't help.... Wait for others to suggest – beeshyams Mar 4 at 12:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.