0

I have my Samsung Note9 (updated, on latest Android 9) connected via USB on Ubuntu Linux, latest platform-tools_r28.0.1. When I run adb shell, it works perfectly. The problem is, the device disconnects after the while (about 30 seconds).

I have the "stay awake" option enabled, but even if the screen remains on, adb keeps disconnecting. I discovered when I prevent the phone from sleeping by touching it, adb remains connected.

Am I do something wrong?

Thanks

  • Try revoking USB authentication, reboot both devices, connect and authorize. May help - guessing – beeshyams Mar 6 at 9:32
  • This scenario seems work: after the first disconnection, switch USB mode to charging only and turn-off, turn-on USB debugging without disconnecting USB. – smrt28 Mar 6 at 9:51
  • Well, if that is consistent you can make that an answer – beeshyams Mar 6 at 9:57
  • hmm, no, it worked just for a little bit longer... – smrt28 Mar 6 at 10:23
  • 1
    Sounds to me like a defect USB port (loose connection) – Robert Mar 6 at 19:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.