1

I know it seems be a repeated question but i have tried every possible solution i found, i have xiaomi redmi s2 with unlocked bootloader and custom treble TWRP recovery and i have a generic system image of AOSIP (GSI) downloaded from here AOSiP-9.0-arm_aonly-GSI-20190217.img

and i have followed this tutorial to flash this image How to flash a Generic System Image (GSI) on Project Treble supported devices.

also tried this tutorial How to install AOSP Extended (Android Pie) on Xiaomi Redmi S2 / Y2 YSL

but my device stuck at boot animation and i have waited more than 20 min also i tried these solutions:

  • wipe data/cache/dalvik-cache.
  • flash no-verity-opt-encrypt.zip (dm-vertiy patch)
  • flash magsik.zip to patch the boot.img
  • reinstall stock boot.img only.
  • try other GSI like AOSP/PIXEL/ViperOS/HavocOS , also it stuck.
  • using fastboot instead of recovery.

I cannot figure out what the problem is. any help?

0

Maybe you forgot to flash miui rom then the gsi files/custom roms (xiaomi miui supported device only). Method 1 : Before flashing GSI files using fastboot first goto twrp and wipe data, cache , dalvik cache then flash the Miui rom for your phone after that flash GSI File using fastboot for your device. Note: after flashing miui ROM don't boot to the os boot directly to the bootloader then flash the gsi file using.

fastboot flash system name-of-your-rom.img

Method 2 : You can flash miui fastboot rom for your device using fastboot then flash gsi/custom rom After flashing fastboot miui ROM for your device reboot to bootloader again using

fastboot reboot bootloader

Then flash gsi/custom ROM file using.

fastboot flash system your-system-image-name-here.img

Method 3 : If you're flashing a custom rom compiled at .zip format you need to wipe system, data, cache partition then flash the miui rom after that flash the custom ROM you want. You don't need to restore your stock boot image when you've installed a custom ROM of course it won't boot and sometimes it does . In some device you need to patch the dm-verity on boot.img if you're installing twrp on a stock rom and flashing magisk doesn't fix your problem.

  • OP mentioned this link, so it is safe to conclude that he did use Twrp. – Firelord Mar 8 at 15:51
  • I think on xiaomi devices you need to flash miui ROM before the gsi files / custom ROMs. – Sean Mar 8 at 15:56
  • I have already tried all these methods you are mentioned but nothing changed – mohamed maher Mar 8 at 16:35
  • What miui ROM version you installed is it android 8.0+? Because gsi files only work on those android versions. – Sean Mar 8 at 16:37
  • yes, it is oreo 8.1 with miui 10 – mohamed maher Mar 8 at 16:38
0

Edit : I forgot to mention that I use the same device as you so this should make all things easier (the links are all for redmi s2) Hey. I had the same problem before. For some reasons you can't flash gsis with the newest miui. Before flashing the gsi download this

Link 1 https://androidfilehost.com/?fid=11410963190603889951.

Link 2 https://sourceforge.net/projects/xiaomi-eu-multilang-miui-roms/files/xiaomi.eu/MIUI-STABLE-RELEASES/MIUIv10/xiaomi.eu_multi_HMS2_V10.2.1.0.OEFCNXM_v10-8.1.zip/download

What to do : 1) boot to TWRP flash the miui file that I mentioned before. 2) wipe data/cache/dalvik-cache/system 3) flash the gsi to system 4) reboot to TWRP again 5) from there you can flash whatever you want (even if you don't want to flash anything still reboot there) 6) reboot to system

Note: some gsis don't support redmi s2 if you are having problems you can try this (and I am sure this one works because I am currently using it)

1) AOSP Extended 6.0 Link : https://downloads.aospextended.com/download/treble_gsi/pie_arm_aonly/AospExtended-v6.0-arm_aonly-20181117-0000-OFFICIAL.zip (there are newer versions but i am not sure if they work)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.