0

I purchased a new Sony Xperia X Compact a while back and ever since the Oreo update the trouble began.

It drained the battery constantly and would not connect to any computer with any type of usb cable or adapters.

I contacted Sony and after 4 months of back and forth they told me that the phone is out of warranty and they cannot help.

I started looking into hardware issues, found not problems, replaced the phone port charger and battery (the new battery I received was faulty and currently I'm waiting for another new one). While still using the old battery I did a factory reset, no help there.

I followed instruction on Sony website to unlock the phone and bootloader (worked with incomplete instructions) as I wanted to flash it, went through enabling developer options ... etc. Nothing I tried worked.

My plan is to install Nougat back or fix the Oreo and be able to connect to a computer using a USB anytime.

Two things I noticed in the phone:

Until last night, the bootloader was greyed out also, when I installed Quick Boot App. Now it magically became alive. It still wouldn't let me restart in fastboot mode and it says that request for superuser permission has been denied.

On another thread I read that if the bootloader is greyed out the bootloader is already unlocked. Is that correct?

The "USB Connectivity > USB connection mode" says "nothing connected" and I am literally connected to the computer as I type this.

I already tried many different cables, adapters and computers. Nothing worked.

Is there Any way to make things work for the USB and battery drain? Thank you!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.