I am constantly getting a notification about every 1 or 5 minutes since I had updated the Google Play Services app. It's a very strange type of notification. It says "Google Play Services won't run unless you update Google Play Services". See the screenshot below : enter image description here

What is the cause of this problem and how to fix it ?

  • 1
    what happens when you touch the notification? does it bring you to play store? – esQmo_ Mar 10 at 13:35
  • No. It is not doing anything. When it is clicked, it just disappears. – Puspam Adak Mar 10 at 15:11
  • hmmmm... try clearing Google Play Service data and see if it solves this? – esQmo_ Mar 10 at 16:06
  • Oh! I am sorry the wrong information, on clicking the notification, Google Play Store does opens up. Actually, previously, play store was disabled, that's why it was previously not launching play store. – Puspam Adak Mar 10 at 16:18
  • So the issue is solved now? – esQmo_ Mar 10 at 16:27

I have solved the problem myself, like this :
Previously, I had updated Google Play Services from an APK file. So, this time, instead of updating Google Play Services from an APK file, I had updated it from the Play Store, and the notification went away.
So, for some reason, updating the app from an APK file was causing the problem.

  • 1
    That's very much usual. Some system apps if updated from external apks, then show problems. – Shamsul Arefin Sajib Mar 28 at 4:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.