1

When any site has mixed content (HTTPS + HTTP), and when you try to open HTTP content, on Desktop chrome, it shows a "shield" icon like screen below,

enter image description here

This allow user to load unsafe script.

However, the above option is not coming or not available when i open the same page in Android phone's chrome browser. My chrome app version is 71.0.3578.99

Any idea how to get above pop-up in android chrome to allow user to load unsafe scripts?

3
  • Can you provide a URL as an example?
    – Firelord
    Commented Mar 14, 2019 at 12:34
  • the 1 i had an issue with i cannot share as i am not the owner of it. But basically this is easy to reproduce on any site whose page-1 is served over https and then page-2 is http. I will see if i can share such an example... Commented Mar 14, 2019 at 12:39
  • Starting with Chrome v79 the desktop version of Chrome will no longer load mixed content: blog.chromium.org/2019/10/…
    – Robert
    Commented Oct 17, 2019 at 12:10

1 Answer 1

1

I just now encountered this problem. On my PC there was a warning "sheild" at the right side of the address bar, and I was able to click it and choose the option of load unsafe scripts. On my Android tablet no such shield was present. Just trying things, I clicked the address line, and it showed the URL along with a short menu of three choices, among them a pencil icon for editing. I chose that, then removed the "s" from the "https" in the URL, and that worked.

2
  • 1
    So, essentially, modify the address to http:// to eliminate the certification checks and the safe route? Spent alot of words there to say that without explaining the danger.
    – wbogacz
    Commented Jun 12, 2019 at 16:31
  • thanks, it works for me. I know there are security issues but i am only working on testing. Commented Dec 25, 2019 at 7:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .